Black screen at login for 10 minutes

I’ve a problem for a while, the login didn’t seem to work using the standard greeter.
The system boots up and the greeter shows login and the system seems to accept the username/password but the screen goes black.
Shifting TTY and login and starting X by commands have been working all the time.
First I thought it was the LightLocker not working since it generated a lot of errors during boot up and people seemed to have the same kind of errors but I uninstalled it and the problems persisted.
Until a couples of days ago I found that if I let the black screen be for about 10 min I get logged in as it should.
Log for a ‘ordinary’ boot up is here:

I would say at row 1551 is the last before it pause and then after about 10 min something happens:

Aug 23 08:53:29 kernel: audit: type=1131 audit(1598165609.520:103): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Aug 23 09:01:01 CROND[1270]: (root) CMD (run-parts /etc/cron.hourly)
Aug 23 09:01:01 anacron[1275]: Anacron started on 2020-08-23
Aug 23 09:01:01 anacron[1275]: Will run job `cron.daily' in 45 min.
Aug 23 09:01:01 anacron[1275]: Jobs will be executed sequentially
Aug 23 09:46:01 anacron[1275]: Job `cron.daily' started
Aug 23 09:46:01 anacron[1275]: Job `cron.daily' terminated
Aug 23 09:46:01 anacron[1275]: Normal exit (1 job run)

I’ve tried reinstalling and swapping greeter
Reinstalling and swapping graphic drivers
Changing between several kernels

I am currently running

Linux kappa 5.7.15-1-MANJARO #1 SMP PREEMPT Tue Aug 11 15:00:37 UTC 2020 x86_64 GNU/Linux


xfce4-about 4.14.1 (Xfce 4.14)

I feel it might be a XFCE error but I might be wrong
Any clues?


It is actually not a problem of XFCE. I would say there is service that expands the login time.

The command systemd-analyze blame should display which service expand the login time. :wink:

Not sure if that is true:

$ systemd-analyze blame 
689ms lvm2-monitor.service                                                     
591ms ufw.service                                                              
583ms systemd-rfkill.service                                                   
467ms dev-sda1.device                                                          
449ms systemd-logind.service                                                   
400ms systemd-random-seed.service                                              
336ms upower.service                                                           
304ms systemd-modules-load.service                                             
291ms systemd-udevd.service                                                    
286ms systemd-timesyncd.service                                                
257ms systemd-journald.service                                                 
231ms add-autologin-group.service                                              
223ms avahi-daemon.service                                                     
200ms NetworkManager.service                                                   
158ms tlp.service                                                              
155ms systemd-journal-flush.service                                            
119ms mnt-a839e6fb\x2d43e8\x2d42fb\x2dba50\x2de7a75c9150b3.mount               
116ms accounts-daemon.service                                                  
112ms lightdm.service                                                          
 97ms dev-disk-by\x2duuid-cfea29fc\x2dfa96\x2d4c6e\x2d8bdb\x2dc559814ea03b.swap
 95ms bluetooth.service                                                        
 91ms polkit.service                                                           
 89ms sys-kernel-config.mount                                                  
 85ms lm_sensors.service                                                       
 79ms mnt-4555d11e\x2dc72d\x2d459c\x2d9844\x2d70a47cacaaae.mount               
 78ms systemd-tmpfiles-setup.service                                           
 63ms udisks2.service                                                          
 59ms org.cups.cupsd.service                                                   
 54ms systemd-sysctl.service                                                   
 52ms user@1000.service                                                        
 51ms systemd-udev-trigger.service                                             
 37ms systemd-user-sessions.service                                            
 22ms systemd-update-utmp.service                                              
 21ms systemd-tmpfiles-clean.service                                           
 19ms tmp.mount                                                                
 15ms systemd-binfmt.service                                                   
 15ms systemd-tmpfiles-setup-dev.service                                       
 13ms dev-hugepages.mount                                                      
 12ms dev-mqueue.mount                                                         
 12ms colord.service                                                           
 12ms sys-kernel-debug.mount                                                   
 11ms sys-kernel-tracing.mount                                                 
 11ms kmod-static-nodes.service                                                
 10ms modprobe@drm.service                                                     
  8ms user-runtime-dir@1000.service                                            
  6ms systemd-remount-fs.service                                               
  5ms sys-fs-fuse-connections.mount                                            
  3ms proc-sys-fs-binfmt_misc.mount                                            
  3ms rtkit-daemon.service

And the startup log only around the selected time:

So it is not a service. Could be your GPU?

Could you post your GPU info?

inxi -Gxxxa

Maybe you have to use this? NVIDIA Optimus - ArchWiki

$ inxi -Gxxxa
    Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia v: 440.100 
               alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c03 
               Display: x11 server: 1.20.8 driver: nvidia resolution: <xdpyinfo missing> 
               OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes

I haven’t tested it but it wasn’t a problem until a couple of months ago.

What about the folders /etc/X11/mhwd.d/ and /etc/X11/xorg.conf.d/ ?
Is there a symlink from /etc/X11/mhwd.d/nvidia.conf to /etc/X11/xorg.conf.d/90-mhwd.conf ?

1 Like

I photographed the boot up sequence from the TTY1, if it might mean anything:

(Not allowed to link or upload…)

What I did was shift between TTY1 and TTY2 then back TTY1 and then the graphical greeter is gone.

Reg. the symlinks, it seems OK:

$ ls -la /etc/X11/mhwd.d/
total 24
drwxr-xr-x 2 root root 4096  7 aug 00.22 .
drwxr-xr-x 5 root root 4096  7 aug 00.16 ..
-rw-r--r-- 1 root root 1653  7 aug 00.22 nvidia.conf
-rw-r--r-- 1 root root 1780  7 aug 00.21 nvidia.conf-100807
-rw-r--r-- 1 root root 1780 18 jun 17.42 nvidia.conf.backup


$ ls -la /etc/X11/xorg.conf.d/
total 28
drwxr-xr-x 2 root root 4096 18 jun 17.25 .
drwxr-xr-x 5 root root 4096  7 aug 00.16 ..
-rw-r--r-- 1 root root  266 25 maj  2018 00-keyboard.conf
-rw-r--r-- 1 root root 2066 31 jan  2020 20-nvidia.conf
lrwxrwxrwx 1 root root   27 25 maj  2018 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf
-rw-r--r-- 1 root root 1689 18 jun 17.24 90-mhwd.conf.backup
-rw-r--r-- 1 root root 1780 18 jun 17.42 95-mhwd.conf

I am sorry for the delay, but only this have to be there:

these ones are possibility conflicting files:

Normally with nvidia there have to be one config files for the GPU. If there are several files with the same Sections then it will not work.

Removed the files, so now:

$ ls -la /etc/X11/xorg.conf.d/
total 16
drwxr-xr-x 2 root root 4096 28 aug 23.42 .
drwxr-xr-x 5 root root 4096  7 aug 00.16 ..
-rw-r--r-- 1 root root  266 25 maj  2018 00-keyboard.conf
lrwxrwxrwx 1 root root   27 25 maj  2018 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

But problem still persist, login did not succeed in 5 min at least.

Did you modify your /etc/X11/mhwd.d/nvidia.conf ?

Do not think I’ve done it myself but maybe something has altered it while installing a new driver and using nvidia own config generator.
I see that mhwd says I have version 430 but nvidia says I have 440.
I will try to get them to be the same.

I do this by removing the nvidia.conf and 90-mhwd.conf and reinstall the driver. It will recreate a default config.

OK so I removed all the old drivers, installed new nvidia drivers 450xx so both nvidia-settings and mhwd says the same:

$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-450xx            2019.10.25               false            PCI


$ nvidia-smi 
Sat Aug 29 20:13:38 2020       
| NVIDIA-SMI 450.66       Driver Version: 450.66       CUDA Version: 11.0     |

rebooting a couple of times still gives the same result.

It must be something that the ‘default’ boot-up does that just starting X doesn’t since it works just starting X from TTY2.

I discovered now, which is a bit embarrassing, that the default run level is TTY7.
So once I enter the correct password and login, the screen goes black but shifting to another TTY-level and back it works.
Its just a matter of removing the ‘black screen’ now.

Could you post a full journal log of your last boot?

jounrnalctl -b -0 > /home/$USER/journal.txt

That will create log in your home folder called journal.txt.

Also your enabled confgs in lightdm.conf could help:

grep -iv "^#" /etc/lightdm/lightdm.conf


$ grep -iv "^#" /etc/lightdm/lightdm.conf

greeter-setup-script=/usr/bin/numlockx on



and the log where I login, shift to TTY6 then back to TTY7:

I am not allowed to use links so:

https: //ufile. io/3ac6sxa7

The log has a duration of about 1min until you typed:

Aug 30 20:21:40 sudo[1225]:   Tim : TTY=pts/0 ; PWD=/home/Tim ; USER=root ; COMMAND=/usr/bin/journalctl -b0 --no-hostname

20:19:17 - 20:21:40
Where are the 9 minutes? :smiley:

If thats the case, than it have to be problem with the monitor, cable or the xorg server that it goes black.

Could you provide thiese logs:



If I just login, the screen goes black for more then 10 minutes then it works BUT if I shift TTY from 7 to something else then back it works.
Sorry, the title might be a bit misleading.

The logs:
https ://ufile .io/f/k5zht

Try to override Monitor detection. Since you are using only DFP, add this to the Device Section in /etc/X11/mhwd.d/nvidia.conf and reboot.

Option "ConnectedMonitor" "DFP"

Hmm made the screen black, could not get any screen at all.
Had to remove the option to get the screen working again.
Very strange…