Black screen after waking up from hibernation

Hello everybody,

I have tried setting up everything according to the documentation, but I am still getting a black screen every time I reboot after hibernating and also waking up after sleep (20 minutes of inactivity).

I have looked into all similar issues reported on the forum, but was unable to find a fix for this issue. Now, at my wits end, I turn to you, dear community. :palms_up_together: If you can guide me in the right direction to solve this, I will be eternally grateful.

Below is my output for inxi -Fazy. If there are any other files (grub, mkinitcpio, fstab etc) you need to have a look at, please let me know and I will add them.

    Kernel: 5.15.74-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
      parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
      root=UUID=a9bc76e4-df97-437c-bb85-6c48bfdc9e78 rw
      resume=UUID=a9bc76e4-df97-437c-bb85-6c48bfdc9e78 resume_offset=12187648
      quiet splash apparmor=1 security=apparmor udev.log_priority=3
    Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
      Distro: Manjaro Linux base: Arch Linux
    Type: Desktop Mobo: ASUSTeK model: Z170-A v: Rev 1.xx
      serial: <superuser required> UEFI: American Megatrends v: 3802
      date: 03/15/2018
    Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
      serial: <filter> charge: 100% (should be ignored) rechargeable: yes
      status: discharging
    Device-2: hidpp_battery_1 model: Logitech M585/M590 Multi-Device Mouse
      serial: <filter> charge: 55% (should be ignored) rechargeable: yes
      status: discharging
    Info: model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S
      gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
      model-id: 0x5E (94) stepping: 3 microcode: 0xF0
    Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
      desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
      desc: 1x6 MiB
    Speed (MHz): avg: 800 min/max: 800/3900 scaling: driver: intel_pstate
      governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 28009
    Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
    Type: itlb_multihit status: KVM: VMX unsupported
    Type: l1tf mitigation: PTE Inversion
    Type: mds mitigation: Clear CPU buffers; SMT disabled
    Type: meltdown mitigation: PTI
    Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
    Type: retbleed mitigation: IBRS
    Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
      prctl and seccomp
    Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
      PBRSB-eIBRS: Not affected
    Type: srbds mitigation: Microcode
    Type: tsx_async_abort mitigation: TSX disabled
    Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel
      arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: none empty: DP-1,
      DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:1912
      class-ID: 0380
    Device-2: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
      v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
      (as of 2022-10) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21
      pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1b80
      class-ID: 0300
    Device-3: Generalplus WEB CAM type: USB driver: snd-usb-audio,uvcvideo
      bus-ID: 1-9:3 chip-ID: 1b3f:1167 class-ID: 0102
    Display: x11 server: v: with: Xwayland v: 22.1.3
      compositor: gnome-shell driver: X: loaded: nvidia gpu: i915,nvidia
      display-ID: :1 screens: 1
    Screen-1: 0 s-res: 2560x1440 s-size: <missing: xdpyinfo>
    Monitor-1: DP-4 res: 2560x1440 hz: 60 dpi: 109
      size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
    OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA
      520.56.06 direct render: Yes
    Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
      driver: snd_hda_intel bus-ID: 1-9:3 v: kernel bus-ID: 00:1f.3
      chip-ID: 1b3f:1167 class-ID: 0102 chip-ID: 8086:a170 class-ID: 0403
    Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
      driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
      bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
    Device-3: Generalplus WEB CAM type: USB driver: snd-usb-audio,uvcvideo
    Sound API: ALSA v: k5.15.74-3-MANJARO running: yes
    Sound Server-1: JACK v: 1.9.21 running: no
    Sound Server-2: PulseAudio v: 16.1 running: yes
    Sound Server-3: PipeWire v: 0.3.58 running: yes
    Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
      port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
    IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
    Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
      driver: btusb v: 0.8 bus-ID: 1-2:2 chip-ID: 0a12:0001 class-ID: e001
    Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 2.1
      lmp-v: 4.0 sub-v: 22bb hci-v: 4.0 rev: 22bb
    Info: acl-mtu: 310:10 sco-mtu: 64:8 link-policy: rswitch hold sniff park
      link-mode: peripheral accept service-classes: rendering, capturing, audio,
    Local Storage: total: 2.27 TiB used: 348.41 GiB (15.0%)
    SMART Message: Required tool smartctl not installed. Check --recommends
    ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
      model: WD1003FZEX-00K3CA0 size: 931.51 GiB block-size: physical: 4096 B
      logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
      rev: 1A01 scheme: GPT
    ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 500GB
      size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
      type: SSD serial: <filter> rev: 2B6Q scheme: GPT
    ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD
      My Passport 0740 size: 931.48 GiB block-size: physical: 512 B
      logical: 512 B type: N/A serial: <filter> rev: 1003 scheme: MBR
    ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%) used: 154.29 GiB
      (33.8%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
    ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
      (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
    Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
    ID-1: swap-1 type: file size: 24 GiB used: 0 KiB (0.0%) priority: -2
      file: /swapfile
    System Temperatures: cpu: 27.0 C mobo: N/A gpu: nvidia temp: 44 C
    Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
    Processes: 223 Uptime: 10m wakeups: 8 Memory: 15.5 GiB used: 2.02 GiB
    (13.1%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
    gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: pm: pacman pkgs: 1612 libs: 475
    tools: gnome-software,pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.22

Could you provide the journal entry of the unsuccessful boot?

So far, it looks like you’ve setup everything correctly, my guess is Nvidia.

1 Like

Do you use the iGPU? If not, disable it from BIOS. Just curios what is shown by:
mhwd -li
and also
cat /etc/X11/mhwd.d/nvidia.conf

Gnome works better with Nvidia GPU and proprietary drivers when you enable early KMS. See here:

(EDIT: I followed the steps from the forum post, but unfortunately the machine does still not wake up properly from hibernation)

You are right, the iGPU does not need to be be active - it’s turned off now (problem still persists, though).

This is the output for mhwd -li:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!

And this is cat /etc/X11/mhwd.d/nvidia.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 515.65.01

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

Just to be sure, this is journeyctl you are referring to, right?
The output file is quite long…

It’s journalctl.

The last boot can be seen with journalctl -b -1.

Ok, those look fine.
Did you run?
systemctl enable --now nvidia-resume.service
and test again?

:grimacing: :sweat_drops: But this has definitely also been a journey so far, as well…
The log is too long to share here (3600+ lines). I’m looking into options to post files on this forum, so once I figure that one out, I will let you know.

Thank you for all the support so far! I enabled the service and gave it another shot, but to no avail.
The computer boots up and I get the motherboard splash screen, but just before the Manjaro login, the screen goes black and I get the “No signal” message. Then the display goes into standby. After a couple of seconds, it turns on again, searching for sources, but can not find any. This repeats three times, and then the display stays off.

When I run systemctl status nvidia-resume.service, I get the following output. Is this alright? I was a bit concerned about the inactive (dead) state…

○ nvidia-resume.service - NVIDIA system resume actions
     Loaded: loaded (/usr/lib/systemd/system/nvidia-resume.service; enabled; preset: disabled)
     Active: inactive (dead)

You could try enabling it: systemctl enable nvidia-resume.service