Black screen after update in Manjaro Gnome

I’m new to Manjaro Gnome, and about a month and a bit ago, after a week of use, I had this black screen problem.

inxi -Fza

Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=manjaro misolabel=MANJARO_GNOME_2122 quiet
systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20VF v: ThinkBook 14 G2 ARE
serial: Chassis: type: 10 v: ThinkBook 14 G2 ARE
Mobo: LENOVO model: LNVNB161216 v: SDK0J40697 WIN
serial: UEFI: LENOVO v: FACN25WW(V1.08)
date: 12/21/2020
ID-1: BAT1 charge: 43.0 Wh (100.0%) condition: 43.0/45.0 Wh (95.6%)
volts: 13.0 min: 11.5 model: 0x43 0x65 0x6C 0x78 0x70 0x65 0x 0x4C 0x31
0x39 0x43 0x33 0x50 0x4500
type: Li-ion serial: status: Full cycles: 100
Info: model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 8 smt: cache: L1: 512 KiB
desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 1396 high: 1397 min/max: 1400/2000 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
3: 1397 4: 1397 5: 1397 6: 1396 7: 1397 8: 1397 bogomips: 31948
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-3:2 chip-ID: 04f2:b6ee class-ID: 0e02 serial:
Display: wayland server: X .org compositor: gnome-shell driver:
loaded: amdgpu note: n/a (using device driver) - try sudo/root
display-ID: 0 resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 05:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: Lenovo driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.43 running: no
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac:
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-4:3 chip-ID: 8087:0029 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Local Storage: total: 534.71 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPMPZ-512G-1101 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: rev: 21160001 temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Wilk model: USB DISK 3.0
size: 57.77 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Alert: No swap data was found.
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 41.0 C
Fan Speeds (RPM): N/A
Processes: 276 Uptime: 44m wakeups: 2 Memory: 13.59 GiB
used: 2.83 GiB (20.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: N/A Packages: pacman: 1209 lib: 307 flatpak: 0 Shell: Zsh v: 5.8
running-in: gnome-terminal inxi: 3.3.12

I have tried the solutions mentioned in similar topics but none of them work for me. I hope someone can help me. Best regards.

Hello @dainse :wink:

Sorry, but this can be anything. Is there anything written?

Since you can run a live session, please try this there:

  1. open a terminal and chroot:
manjaro-chroot -a
  1. edit this file:
nano /etc/default/grub
  1. and remove quiet from the kernel parameter.
  2. update grub: update-grub
  3. sync && exit
  4. reboot

Then when booting you should now see the boot process and see where it hangs.

Also this could help while in chroot:

journalctl --boot -1 --no-pager

Hi megavolt,

Could you provide me the code to Edit the file and to remove the “quiet” parameter (Second and Third step). I am trying to do it but I can’t get it.

Thanks in advance!

if you can enter TTY, you probably dont have to edit kernel or using chroot… in the black screen press: ctrl + alt + f2, if f2 doesnt work try f3-f6 instead of f2


Hi brahma,

I can. I am inside and logged. What should I do now?

good, just run update:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
if everyhing went well, reboot:
systemctl reboot
and report back if you can boot normally into your system

1 Like

The System has been updated without errors but after the reboot the black screen still appears and the desktop still does not start.

ok, enter again TTY and post output from:
mhwd-kernel -li
mhwd -l
mhwd -li

1 Like

ok lets try reinstall kernels and graphics:
uninstall graphics:
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-modesetting
sudo mhwd -r pci video-vesa
reinstall kernel:
sudo mhwd-kernel -i linux515
install graphics:
sudo mhwd -i pci video-linux
sudo mhwd -i pci video-modesetting
sudo mhwd -i pci video-vesa
run these commands:
sudo update-grub
sudo mkinitcpio -P
systemctl reboot
if you still get stuck at the black screen after reboot, run this:
sudo systemctl restart gdm

1 Like

@dainse just remove vesa. That one is the problem. the driver for the amdgpu is included in video-linux.

1 Like

I removed everything and I can’t install now because I don’t know how to select the avaliable Kernel…

mhwd-kernel is not mhwd :wink:

1 Like

run these commands:
sudo mhwd-kernel -i linux515
install graphics:
sudo mhwd -i pci video-linux
sudo mhwd -i pci video-modesetting
then these:
run these commands:
sudo update-grub
sudo mkinitcpio -P
systemctl reboot
dont install again the video-vesa

1 Like

For the Kernel:

You can’t reinstall your current Kernel. Please use ‘pacman -Syu’ instead to update.

we already use the command when we run the update… so just proceed with the rest of the commands:
install graphics:
sudo mhwd -i pci video-linux
sudo mhwd -i pci video-modesetting
then these:
run these commands:
sudo update-grub
sudo mkinitcpio -P
systemctl reboot

1 Like

Thank you very much to both of you.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.