Black screen after switching from nvidia to amd

Hello, friends. Do not scold me, I honestly googled and searched the forum for information.
But never found an answer.
I changed my graphics card Nvidia 1030 to AMD rx 470.
I had video-linux, mesa drivers installed, but after changing the video card and booting the system, only a black screen appeared.
BIOS, SSD password entry (disk encryption) all work fine.
then there is a characteristic crack in the acoustic system (when the graphical shell of the system itself is loaded), but instead of a screen for entering my user password, only a black screen appears.
At the same time, I completely removed the Nvidia and Nvidia-utils drivers, tried installing free and nonfree drivers (mhwd -a pci nonfree 0300), when a black screen appears and you can press Ctrl+Alt+F2.
But all this does not lead to a result. The screen is still black after loading grub. The option to select x11/Wayland is missing. It’s not clear to me how to proceed. I don’t want to reinstall the system. Everything works with livecd.
I tried different kernel versions (5.15, 6.1).
Also I tried to install mhwd -i pci video-linux.
journalctl -b

I try to install new kernel (510)

Also try to install yay vulkan-amdgpu-pro
How to install yay

Looks like you didn’t remove the nvidia xorg configuration file?! Should be in that directory:

ls /etc/X11/xorg.conf.d/

Thank you. Now I will try to install kernel 5.10 and look in this directory.



What to do next?)

5.10 kernel installation result

This file contains normally nvidia configurations made by mhwd.

Check it:

cat /etc/X11/xorg.conf.d/90-mhwd.conf

Rename it:

 sudo mv /etc/X11/xorg.conf.d/90-mhwd.conf /etc/X11/xorg.conf.d/90-mhwd.conf.bck

or if you are really sure, remove it:

sudo rm -fv /etc/X11/xorg.conf.d/90-mhwd.conf

Then reboot.


Now I try to install kernel v6.0-rt.
This file
is empty, but later i will try to do as you suggested

After renaming the file everything worked. Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.