Black screen after resume on Kernel 5.14.7

Having a black screen after resume issue with the latest update (Kernel 5.14.7-2).

Went back to the older linux-firmware and kernel 5.13.19-2-MANJARO. Now it works!

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version:  5.14.7-2 MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
Memory: 13.6 GiB of RAM
Graphics Processor: AMD Radeon™ Vega 11 Graphics

513 is EOL, best is to install 510 and 514
if error with one after update, we select other in grub

1 Like

3 posts were split to a new topic: Can I get a warning about EOL of a kernel?

We’ll all have slightly different criteria, but I’m sticking with linux513 (for now) for 2 reasons:

  1. As a “bleeding edge” AMD CPU (5600X) & GPU (6800XT) user… 510 is lacking (IMO 512 is the minimum kernel for my hardware) and 514 still has some growing pains in the newly available 5.14.7 kernel… [WARNING][AMDGPU] Oops in Linux 5.14.7
  2. linux513 is still the default kernel provided with the new (non-54) Pahvo 21.1.4 ISO’s
1 Like

Your system, your decision, your responsibility and why I’m on 5.10 LTS…

Here is where you can find this information


1 Like

I found the solution here:

Needed to enable IOMMU.

For my Board (Asrock B450M Steel Legend) I found this setting in the BIOS:

Advanced > AMD CBS > NBIO Common Options > NB Configuation > IOMMU (enable)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.