Black screen after performing system upgrade and rebooting

Hey all - I’m new to manjaro and installed a clean version with simple partitioning (GPT) so there is 8mb sda1 unformatted with the bios-grub flag enabled and the rest (sda2 ext4) is for /

It seems that when I run yay and it upgrades the system I can no longer boot on restart. Any ideas?

What do you see when you reboot?

Nothing appears in the screen - I’ve also tested with u ograding with Pacman instead of yay… Same result - can’t boot after power cycle

If you keep pressing “Esc” during boot, do you see the boot menu?

As in, it’s just a blank black screen?

I just see a flashing cursor

Yea just a blank screen unfortunately

In the UEFI menu, the one that appears during boot by holding the “F2” key or something like that, is the feature “Secure Boot” enabled?

This is apparently a legacy boot so it is bios with a master boot record

It looks to me that your boot partition, sda1, is just too small for the boot loader.

In a BIOS system you will be better with a dos partition table, with a single partition for everything.

I won’t use a swap partition, but instead a swap file. That way it can dynamically increase its size as needed.

Alright I tried with a single partition and I also switchwd to uefi mode in the boot… Still no luck - it hangs at boot. I do notice that when I run Pacman -Syu it asks about upgrading the kernel… Should I just not upgrade the kernel? I’ll trying doing an upgrade of everything except the kernel and report back

I thought your system wasn’t capable of UEFI. If it is you are better with UEFI mode, but my latest partition scheme then doesn’t apply.

What is important is disabling Secure Boot and the Trusted Computing Module. You must have a boot partition of at least 260 MiB, using GUID.

For details you can have a look at:

So I realized that it is booting but just showing a black screen because the display manager isn’t stating up. I followed #2 from Welcome to the new Manjaro Forum and was able to get the display manager working using the command startx.

Any ideas how I can fix the display manager issue? I’m using gnome - thanks again for all the help guys

sudo systemctl enable --force
sudo systemctl set-default

SOLUTION for me was to install the correct nvidia driver for the graphics card. So in conclusion it turns out that the system upgrade didn’t prevent the system from booting but rather the old display drivers were not compatible with the new kernel.


you have lost 6h because you do not have provide informations
also helpers too because informations was missing

it cant be done this way
boot on USB iso manjaro
open a terminal

inxi -Fxxxza 
sudo parted -l
sudo efibootmgr -v
test -d /sys/firmware/efi && echo efi || echo bios

for your information
1st install on disk GPT was not EFI install , so calmares has created a bios_grub
you didn’t check in fact if you has really boot USB iso manjaro in UEFI only

I find this response condescending and unhelpful (unlike the helpful community that assisted me yesterday). The issue was not BIOS vs UEFI (I set up correctly for either boot). The issue was that when I updated the kernel the video driver became incompatible which is why the screen was black. My laptop can boot in either UEFI or BIOS (legacy) modes

see the title , see your first post
and it’s in fact trouble video just after first update ?