Black screen after new update

After updating using Pacman I was requested to restart, but now I only get a black screen.

I tried the same procedure with a spare install on a different drive and got this message

“Warning: installing nvidia-utils (460.80-1) breaks dependency ‘nvidia-utils=460.67’ required by linux59-nvidia
Add linux59-nvidia to remove”

Cannot see login screen on original installation, is there a way around this ?

1 Like

Welcome to the forum! :slight_smile:

Please read the linked post below. :arrow_down:

Hi there and thanks for the response, I’m not sure I understand what that means though.
“Due to protobuf update you may need to rebuild that package locally on your end”, how is that possible if I can’t get into the system ?

1 Like

You can chroot into your system from the live session on the install CD/USB.

Boot up from the install medium in live mode, open up a terminal window, and then issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a

Select your Manjaro installation and then follow the instructions in the post I’ve linked to. When you’re done, leave the chroot with Ctrl+D and cleanly reboot your machine. :wink:

1 Like

Thanks, will give that a try

1 Like

You’ll have to chroot in, uninstall the old, EOL kernel as well as the nvidia drivers, install a newer one, and then reinstall the nvidia drivers.

1 Like

Thanks for your response but I’m gonna need a step by step to do that I’m afraid.
I managed to boot into the live session from a USB drive and Chroot to the install and pasted in “sudo pacman -Rdd plasma-desktop-primex” but there was an ‘error not found’ message. I continued and pasted in “sudo pacman -Syu plasma-desktop” which seemed to complete OK but still getting the black screen.

This seems to be an Nvidia driver issue so would installing a Radeon GPU bypass the problem ?
I have a spare one that I could try

OK, so be not afraid.

  1. Boot into the Live ISO environment. (Which it seems you have done.)
    1.1. If you wish, open this page in a browser as reference.

  2. Open a terminal and chroot into your Manjaro installation:

manjaro-chroot -a

Be careful now: You are now working on your installation as root!

  1. Once in the chroot environment, uninstall the faulty kernel:
mhwd-kernel --remove linux59
  1. While you’re at it, you can just as well remove the nvidia drivers. To do so we must first identify the drivers installed. To do that run the following in the chroot environment:
sudo mhwd --listinstalled

You should get a result similar to this:

> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-nvidia            2020.11.30               false            PCI

From the output we can clearly see that the nvidia driver that has to be uninstalled is video-nvidia, so to remove it run:

mhwd --remove video-nvidia
  1. Now reinstall the kernel for your system. I suggest kernel version 5.4 or 5.10 as they are LTS. To install version 5.10, run:
mhwd-kernel --install linux510
  1. Follow that by reinstalling the nvidia driver:
mhwd --install video-nvidia
  1. Hold your thumbs, cross your heart, say a little prayer to Brigid, and reboot.

Theoretically, it should be fine now. If not, I don’'t take responsibility. If it is, however, feel free to heap on the praise!

No, it’s not really an nvidia thing. it’s because the nvidia drivers want to use kernel 5.9, which has been EOL for some time now, so the ATI GPU won’t help. I think.


Thanks again for your help and patience but I hit a snag at step 3.

After pasting in `mhwd-kernel --remove linux59’ I got

‘ERROR; you cannot remove your current kernel’

Are you doing that from thee chroot environment? Because, I don’t think that should happen from a chroot environment.
Regardless, switch the order up by first installing the new kernel (in the chroot environment, of course):

mhwd-kernel --install linux510

Then exiting the chroot environment:


and rebooting the system, starting up with the Live ISO environment again. Then enter the chroot environment, as before, and remove kernel version 5.9:

mhwd-kernel --remove linux59

Continue with the previous instructions from there.


I am following your instructions very carefully;

First, Boot into the Live ISO environment. No problem

Opened web page in live environment browser to access this thread and copy instructions, no problem.

Second, Open a terminal and chroot into your Manjaro installation:, simple enough with ‘manjaro-chroot -a’.

Third, install new kernel with ‘mhwd-kernel --install linux510’, no problem.

EXIT and reboot back into live environment, open Terminal then start chroot process again then entered
‘mhwd-kernel --remove linux59’ and got

‘ERROR; you cannot remove your current kernel’

I’m stuck !

Then install the Nvidia driver for kernel 5.10.

Then boot the system with kernel 5.10.

Remove kernel 5.9. But from chroot there should be no error removing kernel 5.9.

Thanks for your input Keruskerfest but I my problem is blacking out the screen which is why I am trying to do this from a live environment.
Does the error 'cannot remove your current kernel’ not matter then, should I just ignore it and continue removing the Nvidia drivers and then re-installing them ?

Can you start the installed system,
switch to console and install kernel 5.10 and the Nvidia driver ?

No, that’s the problem, I just have a black screen after updating and am trying to fix it using a Live Environment on a USB drive and opening a Terminal to navigate into the faulty installation using chroot.
When I tried to remove the kernel it won’t let me.

Can you try to install the latest LTS kernel 5.10 with chroot ?

I am using Linux Kernel 510 LTS with manjaro gnome.
I am having the same black screen problem after update as well, I followed a bunch of solutions on forums (like removing proprietary nvidia drivers), it worked, I could log in to my device (although the some icons & display were looking weird). Then I installed free nvidia drivers from manjaro setting GUI & rebooted, back to the black screen. I am tried removing the drivers & rebooting, but it didn’t work. I can access my tty terminal using CTRL+ALT+F2, thats where I followed all the instructions. Please help.

As far as I can tell I did install kernel 5.10 with chroot, but it won’t let me remove 5.9, maybe if I remove 5.10 and reinstall it, would that make any difference ?

This might be a bit off-topic, but I’m facing similar issues since yesterday’s update. I have tried via manjaro-chroot -a several kernel versions (5.10 first and went even back to 5.4) with the proprietary Nvidia drivers. Unfortunately none of those seems to work any longer and the machine remains in black screen. The free driver seems to work fine, but I’d like to use the machine for gaming as well, what creates kind of a dealbreaker here.

Are there some general issues with Nvidia’s drivers at the moment?