Black screen after messing with some xorg files

A couple months ago I was messing around with some files so i could remote into my windows desktop, i was lazy and didnt fix it at the time. On start I can log into bash after pressing ctrl alt f2, but startx wont work. I have attached some files and logs, i can provide more if it would be helpful.

the correct command is startx not start x

one second, im ganna upload some logs and my xinitrc file

>systemctl status lightdm.service 
× lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sat 2022-06-04 06:53:39 EDT; 13min ago
       Docs: man:lightdm(1)
    Process: 693 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 693 (code=exited, status=1/FAILURE)
        CPU: 11ms

Jun 04 06:53:39 vivo systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Jun 04 06:53:39 vivo systemd[1]: Stopped Light Display Manager.
Jun 04 06:53:39 vivo systemd[1]: lightdm.service: Start request repeated too quickly.
Jun 04 06:53:39 vivo systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jun 04 06:53:39 vivo systemd[1]: Failed to start Light Display Manager.
>cat /.xinitrc
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
 
> inxi -Fazy

System:
  Kernel: 5.16.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=705310b0-f208-4af7-a4b3-01c8f79d1d06 rw quiet
    cryptdevice=UUID=92725f83-e59a-45de-a485-2987afbf340c:luks-92725f83-e59a-45de-a485-2987afbf340c
    root=/dev/mapper/luks-92725f83-e59a-45de-a485-2987afbf340c apparmor=1
    security=apparmor udev.log_priority=3
  Console: tty 2 DM: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X512FA_X512FA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X512FA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X512FA.300 date: 04/02/2019
Battery:
  ID-1: BAT0 charge: 22.5 Wh (92.2%) condition: 24.4/37.1 Wh (65.6%)
    volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Charging cycles: 670
CPU:
  Info: model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1369 high: 1400 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1400 2: 1400 3: 1400
    4: 1400 5: 1400 6: 1360 7: 1299 8: 1300 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: ASUSTeK
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:2 chip-ID: 13d3:56d3 class-ID: 0e02 serial: <filter>
  Display: server: X.org 1.21.1.2 driver: loaded: modesetting
    alternate: fbdev,vesa tty: 240x67
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: no
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: AzureWave driver: ath10k_pci v: kernel bus-ID: 01:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-10:3
    chip-ID: 13d3:3491 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Drives:
  Local Storage: total: 476.94 GiB used: 14.37 GiB (3.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 004C temp: 26.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 212.73 GiB size: 208.34 GiB (97.93%)
    used: 14.35 GiB (6.9%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-92725f83-e59a-45de-a485-2987afbf340c
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.4 MiB (26.5%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 43.0 C pch: 35.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2000
Info:
  Processes: 175 Uptime: 15m wakeups: 1 Memory: 7.62 GiB
  used: 457.5 MiB (5.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1135 lib: 319 flatpak: 0 Shell: Bash (login)
  v: 5.1.12 running-in: tty 2 inxi: 3.3.11

this is very likely the reason you have issues: Kernel: 5.16.0-1-MANJARO - that kernel is not supported, do you have installed other kernels?

yes I have 5.15.7 and 5.10.89

so you didnt even run the latest stable update…
post output from:
find /etc/X11/ -name "*.conf"

/etc/X11/xorg.conf.d/00-keyboard.conf
/etc/X11/xrdp/xorg.conf

so remove this:
sudo rm /X11/xrdp/xorg.conf
then reboot and select in grub menu the 5.15 kernel
hopefully youll normally boot and then uninstall the 5.16 kernel

thanks, in the meanwhile i ran Syyu

dont run update, until you switch from the 5.16 kernel…

i ran it from the 5.10

so you were not running the 5.16… so if thats the case you can uninstall it…

okay, did all that, still same failure

post again output from:
find /etc/X11/ -name "*.conf"
and from:
mhwd -l && mhwd -li

/etc/X11/xorg.conf.d/00-keyboard.conf

> 0000:00:02.0 (0300:8086:3ea0) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

so try reinstalling video drivers:
log out and enter into tty - alt+ctrl+f2
uninstall:
sudo mhwd -r pci video-linux
install again:
sudo mhwd -i pci video-linux
reboot:
systemctl reboot

Now i cant even get into bash