Black screen after installing Blender

I’m using Manjaro in my laptop and after installing Blender and rebooting the system because I wasn’t able to start Blender, I see no login screen, just a black screen with the mouse pointer, but nothing else.
I’ve been reading about similar issues and I think it can be related to my Nvidia card and something Blender has to install in order to work.
But I don’t know where to go from here or what to do.
I’ve tried running the terminal with the Ctrl-Alt-F2 sequence and I can access the terminal, but I have no idea where to go next.
Could you help me with this or something?

I’m pretty new to this after being some years without using Linux (Debian), but I was somewhat familiar with the CLI.


You could have a look into /var/log/pacman.log and check which packages have been installed together with Blender.

I forgot to say that I removed blender from the CLI doing a chroot from a live system.
But that didn’t fix the issue.
I tried the nvida-settings command but I can’t configure my card.
I think it has to do with the drivers…

Okay, I solved it.
Apparently it was the drivers.
First I had to use the command line (Alt Ctrl F2), because the logging screen or the graphics weren’t working.
After logging in, I checked the drivers:
$inxi -G

And I listed the available ones:
$mhwd -l

I tried to install the proprietary drivers from NVidia, but I had no Internet connection (WiFi), so I used the NetworkManger interface:
$ nmcli device wifi list
$ nmcli device wifi connect SSID password password

After that I could install the new drivers with:
sudo mhwd -i pci video-nvidia-340xx
(340xx was my version, yours could be different)

And after rebooting my system, everything was okay again.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.