Black screen after GRUB

Hi, I’m kinda new to linux, I installed Manjaro recently (dual boot) with Gnome, changed some theme settings and installed chrome.

The day after, I received an error after login: oh no! Something has gone wrong… (ends with logout and try again or something)

Tried: rebooting, switching from nouveau to nvidia drivers, reinstalling GDM and Gnome session, disabling extentions (with gsettings… although I’m not sure this worked, before the error I can briefly see the themed cursor), nothing semms to have fixed it. Root can login and works fine. Journalctl says something along the lines of: cannot start gnome desktop on X11.

Today, not even the login screen shows, I get a black screen right after GRUB. I can use the terminals (ctrl alt f3…), journalctl has the following errors:

Failed to find module ‘platform integrity’
Kernel reports: Attribute failed policy validation
Failed to create interface p2p-dev-… (invalid argument)
Failed to create a P2P device interface
3 soft-audio-pci errors: request firmware failed err -2, …
Process Xorg of user 120 dumped code:… (has abort, os abort and fatal error at the beginning)

I tried doing startx, the current console freezes, unrecoverable failure in required component

In the full output of journalctl, i see a bunch of stack trace forcontext … ==
With nothing after the == for

(sorry but I can’t think of a way to copy paste the text here, I can only work from the command line, unless there are specific log files I can copy from windows)

I should say that I mistyped my password once or twice before printing the jounal, not sure if that added extra errors.

I’m new to this so please follow up any instructions with concrete command lines, thanks so much in advance for any help.

I’m not sure of any other logs I need to provide, I’ll gladly follow up if any are needed.