Black Screen After Boot - Nvidia Drivers Issue?

Hey everyone! I’m at a bit of a loss for how to fix my current issue, and I consider myself a novice, so please bare with me.

I recently performed an update, after which I could not fully boot. The computer turns on, goes to the GRUB menu, after I proceed, the motherboard logo pops up but then my screen just goes black. All my searching led me to believe it was an issue with Nvidia drivers which seems pretty common, but I’ve followed various forums including the recent post about compiling legacy drivers, none of which have helped.

I’ve tried removing all drivers, regressing to various older kernels, with older drivers, kernel 5.10 with new drivers, auto hardware detection… I’ve even tried resorting to the free drivers. All to no avail. The last point makes me wonder if it could be something other than the drivers, but I honestly don’t know.

The only way I can currently access my device is by going to boot options and replacing ‘quiet’ with ‘3’ leaving me at TTY, so it will be difficult for me to post command line outputs, but I will do my best to provide any info that may help.

Current Specs:
Kernel: 5.10
CPU: Ryzen Threadripper 1920X
GPU: GTX1070