Black box around mouse pointer after most recent updates

I Installed the most recent set of updates and now I have a black box around my mouse pointer. I tried to take a screenshot to illustrate the problem but the box doesn’t appear on the captured image. The mouse pointer is at the top left corner of a black square that is about 4 times the width (and height) of the pointer and follows it around.

Manjaro-ARM on Rpi 4B
KDE Plasma Version 5.24.2
KDE Frameworks Version 5.91.0
Qt Version 5.15.2
Kernel Version 5.15.24-1-MANJARO-ARM-RPI (64-bit)
Graphics Platform Wayland

Does it happen on X11 too?

If it does not, it seems likely to be a wayland driver issue for the Raspberry Pi gpu driver.

I tried to boot into an X11 session yesterday and had to restore from a backup because… I don’t know what happened. I’m not trying it again :slight_smile:

Okay. So we can’t find out what the issue is then.

The above is my theory though.

Yeah fair point. I tried again. The mouse pointer is fine in an X11 session. But the desktop performance isn’t. It’s barely useable.

Hello @Strit and @Blarg -

I am running the ARM testing version of Manjaro on my Raspberry Pi 400 and can confirm that I also have the same issue with a black box around my mouse pointer when using Wayland. However, the pointer is fine when using X11. This issue remains present with Wayland even after the latest 2022-03-13 ARM testing updates but X11 remains unaffected. Here is some info about my Pi 400:

Operating System: Manjaro-ARM
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Kernel Version: 5.16.12-1-MANJARO-ARM-RPI (64-bit)
Graphics Platform: X11
Processors: 4 × ARM Cortex-A72
Memory: 3.5 GiB of RAM
Graphics Processor: V3D 4.2

Desktop performance on my end is fine with X11 but I am also overclocking my Pi to 2350 MHz, which I’m sure helps quite a bit.

I hope this helps!

So far the common thing here is it’s using V3D driver and Plasma Wayland session.

I’m wondering if the same issue is present on Gnome Wayland and Sway?

If they are it’s a GPU driver issue. If it’s not, it’s something Kwin does in wayland, that the driver does not support.

I do not use those DE’s but there are 2 KMS V3D modes to boot into. Wonder if both modes were tried to see if anything is different.

dtoverlay=vc4-fkms-v3d    # Uses RPi's firmware
dtoverlay=vc4-kms-v3d     # Bypasses RPi's firmware and uses the kernel firmware

I only tried the default one. I’ll try it with the other.

Another thought is turn off animation/compositing.

Not possible to turn off compositing on a wayland session though.

EDIT: Just tried it with kms, instead of the default fkms. The black box is gone, but the colors of the mouse pointer is very weird now.

Same issue on my Raspberry Pi 400:

  • a black box around mouse pointer when using Wayland with “dtoverlay=vc4-fkms-v3d”
  • bad color mouse pointer when using Wayland with “dtoverlay=vc4-kms-v3d”

I fix with KWIN_DRM_NO_AMS=1 (eg. in /etc/environment).

Appears to be issues with AMS cursor.
The same setting appears to fix also constantly consuming 20-60% of a CPU core.

1 Like

This fixes it with fkms or regular kms?

With kms. I haven’t tried with fkms yet.

EDIT: Confirm also fix fkms.

1 Like

And no negative effect on an X11 session?

No, no negative effects in X11 session.

I believe this revert ( will solve the problem at the source by avoiding the use of KWIN_DRM_NO_AMS = 1. I await the next kernel compilation and update you. So you can eventually remove the setting from rpi4-post-install.

I installed some updates a day or two ago (haven’t been using the Pi for a while) and the black box around my mouse pointer is gone.