Bizarre umount issue

My Raspberry Pi acts as my fileserver. My 4TB harddrive is attached to and shared by the PI. This NFS share is mounted on my main system in /etc/fstab. I just rebooted the Pi and now dolphin is hanging on my main system. Konsole/guake/terminator hang as soon as I type the last letter of the share while attempting a umount (I never get a chance to hit enter). What’s even more strange is that my sudo password is no longer accepted (yes, I am certain I’m typing the correct password). I am about to switch to root user strangely enough.

I know that when I reboot things will get back to normal but I used to be able to reboot my RPI without these issues in the past. I wonder what has changed.

It is normal that disappeared network mounts will hang the system.

It is recommended to use systemd mount and automount for network shares.

@linux-aarhus is right about systemd unit, it’s also safer to do it so, so you don’t mess up your fstab in case you make some errors, which could cause your system not being able to boot.

Nonethless you can also try to add


in the options of your nfs mount if you want to stick with fstab

What does the command sudo systemctl status mnt-wdrexxxx.mount gives ?

Replace wdrexxxx by the real name in your system.
And also, try to do a normal umount (without -A)

@linux-aarhus Let me read up on that. Thanks!

@yannssolo I had to reboot so the problem has resolved itself. Here is my fstab entry. I think it contains the elements you mentioned. /mnt/wdred nfs _netdev,noauto,x-systemd.automount,noatime,x-systemd.mount-timeout=9,x-systemd.idle-timeout=1min 0 0

I don’t recall this problem occurring before but since I hardly ever reboot my RPI, I can’t say for sure :confused:

There could be a lot of explanations.

After your system has started, if for some reason you mount/unmout your share manually, be careful because:
If you mount with sudo mount -a, it will not work because of the noauto, even if you have x-systemd.automount.