Bios return "No bootable device" after 2 days using manjaro on LUKS

Hi All! I’m using Manjaro latest 2 years, always fix every problem by reading these forums, but couldn’t fix this one. Is my first time using manjaro on a LUKS encrypted device.

I changed my HDD 2 days ago because the old one had several damages, tryed to make a manual partition to just encrypt 1 partition but couldn’t make a right install. So at the end I’ve installed with full encryption (no partitions), and swap with hibernation, also encrypted.

System was working just fine, updated everything, and installed just a few things to start working: brave, vscodium, nodejs and github-desktop from aur. Also I’ve installed the last kernel. This morning I was making a react app, everything was just fine, then I shutdown and after a nap, when I power my laptop bios return this message:

"Non bootable device found".

I check first the BIOS menu, and there is not any device available neither.

So I plug a live usb to check whats going on, I have plenty access to my device from live usb. When I mount my passphrase is ok, I have access to all my files, even those which I was working before shutdown. Everything is there, but still can’t boot.

I have low experience fixing linux more than the ussual as restore grub and fsck, so if you can help me to troubleshooting this I will be very thankfull, in the mid time I will keep working with the old damaged device.

Here are some commands and files that I was checking:

[manjaro@manjaro ~]$ inxi -Fza
  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2107 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: TOSHIBA product: Satellite L305D v: PSLCJU-002002 
  serial: <filter> Chassis: AMD type: 10 serial: <filter> 
  Mobo: TOSHIBA model: Portable PC serial: <filter> BIOS: Insyde v: 1.80 
  date: 09/01/2009 
  ID-1: BAT0 charge: 1.9 Wh (67.9%) condition: 2.8/43.2 Wh (6.4%) 
  volts: 10.8 min: 10.8 model: PA3534U-1BRS type: Li-ion serial: <filter> 
  status: Unknown 
  Info: Single Core model: AMD Sempron SI-42 bits: 64 type: UP 
  arch: Turion X2 Ultra family: 11 (17) model-id: 3 stepping: 1 
  microcode: 2000057 cache: L2: 512 KiB 
  flags: lm nx pae sse sse2 sse3 bogomips: 4201 
  Speed: 1050 MHz min/max: 1050/2100 MHz Core speed (MHz): 1: 2100 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD RS780MC [Mobility Radeon HD 3100] vendor: Toshiba 
  driver: radeon v: kernel bus-ID: 01:05.0 chip-ID: 1002:9613 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: ati,radeon 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") 
  s-diag: 398mm (15.7") 
  Monitor-1: LVDS res: 1280x800 hz: 60 dpi: 98 size: 331x207mm (13.0x8.1") 
  diag: 390mm (15.4") 
  OpenGL: renderer: AMD RS780 (DRM 2.50.0 / 5.10.42-1-MANJARO LLVM 12.0.0) 
  v: 3.3 Mesa 21.1.2 compat-v: 3.0 direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: Toshiba driver: snd_hda_intel v: kernel 
  bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba 
  driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Realtek RTL8187B Wireless Adapter type: USB driver: rtl8187 
  bus-ID: 1-6:4 chip-ID: 0bda:8198 class-ID: 0000 serial: <filter> 
  IF: wlp0s18f2u6 state: up mac: <filter> 
  Local Storage: total: 480.48 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM021-1KJ152 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: YXM1 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: Flash Disk 
  size: 14.72 GiB block-size: physical: 512 B logical: 512 B rotation: SSD 
  serial: <filter> rev: 8.07 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No partition data found. 
  Alert: No swap data was found. 
  System Temperatures: cpu: 69.9 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 176 Uptime: 12m wakeups: 1 Memory: 2.67 GiB 
  used: 1.57 GiB (58.9%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1133 lib: 300 flatpak: 0 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.04 
[manjaro@manjaro ~]$ lsblk -f
NAME   FSTYPE      FSVER         LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squashfs    4.0                                                                        0   100% /run/miso/sfs/livefs
loop1  squashfs    4.0                                                                        0   100% /run/miso/sfs/mhwdfs
loop2  squashfs    4.0                                                                        0   100% /run/miso/sfs/desktopfs
loop3  squashfs    4.0                                                                        0   100% /run/miso/sfs/rootfs
├─sda1 crypto_LUKS 1                               3c0804d8-3c05-46a5-912d-2662f8c26d49                
└─sda2 crypto_LUKS 1                               abfd195d-6622-44de-9a28-2b92c72d4c2d                
sdb    iso9660     Joliet Extens MANJARO_XFCE_2107 2021-06-14-15-23-05-00                     0   100% /run/miso/bootmnt
├─sdb1 iso9660     Joliet Extens MANJARO_XFCE_2107 2021-06-14-15-23-05-00                              
└─sdb2 vfat        FAT12         MISO_EFI          0545-B0D1                                           


# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
/dev/mapper/luks-3c0804d8-3c05-46a5-912d-2662f8c26d49 /              ext4    defaults,noatime 0 1
/dev/mapper/luks-abfd195d-6622-44de-9a28-2b92c72d4c2d swap           swap    defaults,noatime 0 0


GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=3c0804d8-3c05-46a5-912d-2662f8c26d49:luks-3c0804d8-3c05-46a5-912d-2662f8c26d49 root=/dev/mapper/luks-3c0804d8-3c05-46a5-912d-2662f8c26d49 apparmor=1 security=apparmor resume=/dev/mapper/luks-abfd195d-6622-44de-9a28-2b92c72d4c2d udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:
[manjaro@manjaro ~]$ sudo blkid
/dev/loop1: TYPE="squashfs"
/dev/sdb2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="0545-B0D1" BLOCK_SIZE="512" TYPE="vfat"
/dev/sdb1: BLOCK_SIZE="2048" UUID="2021-06-14-15-23-05-00" LABEL="MANJARO_XFCE_2107" TYPE="iso9660"
/dev/loop2: TYPE="squashfs"
/dev/loop0: TYPE="squashfs"
/dev/sda2: UUID="abfd195d-6622-44de-9a28-2b92c72d4c2d" TYPE="crypto_LUKS" PARTUUID="8f48f226-02"
/dev/sda1: UUID="3c0804d8-3c05-46a5-912d-2662f8c26d49" TYPE="crypto_LUKS" PARTUUID="8f48f226-01"
/dev/loop3: TYPE="squashfs"

So well… it is pure BIOS:

and you have only an encrypted root:

What do you think? Does the BIOS support the decryption of LUKS? On EFI or on BIOS: You need at least one partition which is not encrypted.

  1. EFI → EFI Partition
  2. BIOS → Boot Partition

So it is clear, why it cannot boot it, but I guess a Manjaro Boot Disk is able to boot it.

so I should reinstall with manual partition? I tryed to install 2 times with manual partition but after successful install couldn’t boot the system. (with home/swap/root encrypted and boot partition unencrypted)

Or just forget about LUKS… I will get a new more modern computer in about 6 months but right now this is what I have.

I don’t think this is a LUKS problem. This machine was running the disk on LUKS just fine for two days, anyway: I’ve reinstalled:

manual partitioning, unencrypted boot → “no bootable device”
full disk NO LUKS → “no bootable device”.

My bios menu still no recognizing the HDD, when I access the bios at startup on HDD section says “none”.

Booting again on live usb,
e2fsck : /dev/sda1: clean, 285287/30146560 files, 3801350/120555004 blocks


[manjaro@manjaro ~]$ sudo smartctl -a /dev/sda
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.42-1-MANJARO] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke,

Model Family:     Seagate Laptop HDD
Device Model:     ST500LM021-1KJ152
Serial Number:    W624BNHN
LU WWN Device Id: 5 000c50 082cbe188
Firmware Version: 0002YXM1
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Form Factor:      2.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is:    Sun Jan  9 10:30:44 2022 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(    0) seconds.
Offline data collection
capabilities: 			 (0x53) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					No Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  78) minutes.
SCT capabilities: 	       (0x103d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x002f   118   099   006    Pre-fail  Always       -       193935520
  3 Spin_Up_Time            0x0023   099   098   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   099   099   000    Old_age   Always       -       1458
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002f   084   060   030    Pre-fail  Always       -       270839418
  9 Power_On_Hours          0x0032   089   089   000    Old_age   Always       -       9757
 10 Spin_Retry_Count        0x0033   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       1454
183 Runtime_Bad_Block       0x0032   100   100   000    Old_age   Always       -       0
184 End-to-End_Error        0x0033   100   100   097    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Command_Timeout         0x0032   100   100   000    Old_age   Always       -       4295032833
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   066   051   045    Old_age   Always       -       34 (Min/Max 27/34)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       9
192 Power-Off_Retract_Count 0x0022   100   100   000    Old_age   Always       -       29
193 Load_Cycle_Count        0x0032   098   098   000    Old_age   Always       -       4772
194 Temperature_Celsius     0x0022   034   049   000    Old_age   Always       -       34 (0 19 0 0 0)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0
254 Free_Fall_Sensor        0x0032   100   100   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Interrupted (host reset)      00%         2         -

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST500LM021-1KJ15 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  494GB  494GB   primary  ext4            boot
 2      494GB   500GB  6311MB  primary  linux-swap(v1)

I’ve reinstalled grub, again, don’t know what else to do. BIOS still not recognizing this brand new HDD, when I plug the old one (damaged) is recognized, and manjaro starts correctly. Could be a hardware problem for the new HDD? or live usb?

Is your system fully updated? It looks like you are running kernel 5.10.42 and Stable is currently at 5.10.89

Probably bootorde misformed after upgrading firmware? You could try:
Use a live-usb, and select from the options menu your EFI bootloader, you should be able to get into your system again.
Once in your system check with efibootmgr if there is a manjaro bootoption.

oh that kernel is from live usb. I ran those commands just after install and failed to boot. I had same result with the last kernel before reinstalling.

I have no EFI support is an old toshiba insyde.

I tested the HDD today in another computer and works perfectly, I think is a hardware problem. The only way to boot is using my old damaged hdd, or the live USB, Idk why. I’m giving up with this I think until can change this laptop.

You probably need to chroot and instal Grub again.

1 Like

I tryed several times, I updated the system in chroot without errors in dev/sda but everytime I reinstall Grub throws me an error about /dev/sdb (which is my live usb). I did this when I had the luks encryption, I will try again now that I’ve reinstalled without encryption, and paste the exact error here and commands, maybe I’m doing something wrong. I will reply later.

yeah! that worked this time without encryption. Last time I let the script find the disk without luck. But I pointed the name of disk this time and worked. Thanks.

I still don’t have a clue how screwed the grub without any update, or installing anything. I was passed the last 2 days with the system already updated, just working with npm packages at local level. Anyway, thanks all for the help.

1 Like

sorry, no is not solved. After second restart, I lost the grub again… It happens with every restart. I have to use live usb every time to reinstall grub or boot with the option “boot bios system”.

Can be this a problem of the hard drive? some factory deffect? because if is that so I still have some days to ask for refund or devolution.

Is it possible that you installed in Legacy mode but try to fix Grub from booting in UEFI mode?

Not sure what means Legacy mode, I run installer in spanish. When I install with full disk option using calamares, made only 2 partitions. 1 is for swap. And made a MBR partition table. Grub was installed on /dev/sda (not a dedicated partition, the full disk I mean).

Then for reinstalling grub I follow this guide from the wiki: GRUB/Restore the GRUB Bootloader - Manjaro

Exactly these 3 commands:

manjaro-chroot -a
grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sda

Response was “done, no errors to report” (something like that, I’m translating from spanish)

grub-mkconfig -o /boot/grub/grub.cfg
Response was “Done”

1 Like

looks correct

I don’t know why Grub gets reset each time. Might be some BIOS setting. Is it an option fo you to use another boot device? Do you have another HDD to check if that one would also get reset?

No I don’t have much options for hdd:

Sata controller mode: AHCI/compatibility (I use compatibility, but tryed the other one just in case and nothing changes)
Password, and the option to select hard drive which can’t be selected and don’t recognize any HDD.

Well and also the boot options, I have HDD in first place now (was usb before)

No uefi support. It’s weird never happened to me that bios don’t recognize the drive even with an empty drive.

The only other HDD that I have to test is my old HDD, is damaged and that is the reason I buy a new one, have a lot of damaged blocks and I have to run e2fsck 2 or 3 times per day to work because suddenly I get my system turned into “only read system”. I managed to sync my work with guthub so I don’t lose to much work, then reboot > fsck > fix everything and again.

but it still works, in fact I’m working with that one now, still booting manjaro just fine, and have almost the same software and stuff that the new one.

Well, the seller scan the disk and won´t make a devolution. Just get tired, I bought another one (thoshiba), this works fine, I will use the one with the problem as backup with an usb adapter for now.

best of luck with that

1 Like

I think I find the problem, I reply just for any one that is having same issue.

I tested 7 different HDD, some damaged, and a coouple of new or almost new ones. I get this error always with 7200 rpm HDD. With 5400rpm HDD this don’t happen. I guess this old laptop can’t work with more than 5400. Only affects GRUB don’t know why, but thats the thing.

7200 rpm will lose grub.
5400 rpm works nice.

And this is not true, I have a new HDD working with luks, with this BIOS and everyhting encryted. working just fine for at leats the last week

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.