BIOS only shows Manjaro installed usb devices

I have a laptop that came with Windows 10 and I wiped the disk to install Arch. But I screwed up on the bootloader or grub stuff (probably) and It didn’t boot. So after that I decided to install Manjaro. Everything went well and 1 - 2 months passed. Today I tried to install Pop OS with the same laptop but inside the boot menu I see nothing about my usb drive. After that I also tried with other usb drives with different distros (xubuntu) and also windows but nothing about usb drivers showed up (different computers and laptops showed all the usb drives). I tried to install Manjaro and it’s showed up (but I didn’t installed it). I tried etcher with Latest Fedora Workstation, Pop OS and Arch Linux, none of them worked.

I think I damaged something about efibootmgr but not sure.

Here are my current efibootmgr -v results:

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001,0000,0004,2002,2003,0002
Boot0000* Manjaro       HD(1,GPT,5a8f3754-ba72-3847-8bea-adb89fe05f9e,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* EFI PXE 0 for IPv4 (B4-A9-FC-4B-61-B6)        PciRoot(0x0)/Pci(0x1d,0x1)/Pci(0x0,0x0)/MAC(b4a9fc4b61b6,0)/IPv4(,0,0)RC
Boot0002* Internal EFI Shell    MemoryMapped(11,0x8a913080,0x8b5aa07f)/FvFile(7c04a583-9e3e-4f1c-ad65-e05268d0b4d1)RC...D
Boot0004* EFI Hard Drive (KINGSTON SA400M8240G) PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,5a8f3754-ba72-3847-8bea-adb89fe05f9e,0x1000,0x96000)RC
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC

Thanks :slight_smile:

On the Grub Boot menu, you will not see you flash drive, but on the UEFI Bootmenu there it should be visible:

So Manjaro screwed nothing here.

Ok, but I don’t understand why my laptop only accepts Manjaro installed usb drives while my other laptop and pc accepts all different installation mediums :thinking:

Maybe it does not recognize correctly the EFI Partition on the flash drive? Did you try ventoy?

Wow ventoy looks like a super tool. I installed it and throw my manjaro and pop os inside it. Ventoy works with my main machine but still it’s not works on my laptop.

Here are the information about my ventoy installed usb stick:

      Ventoy: 1.0.51  x86_64

Ventoy Version in Disk: 1.0.51
Disk Partition Style  : GPT
Secure Boot Support   : YES
1 Like

It’s worked! I tried ventoy with the default configuration and it’s worked :smiley:

Thank you @megavolt soooo much.

Here are my ventoy settings:

Ventoy Version in Disk: 1.0.51
Disk Partition Style  : MBR
Secure Boot Support   : NO
1 Like

Just a side note: UEFI specifications differ and therefore it can be possible that methods to boot USB Drives do not work.

Specifications | Unified Extensible Firmware Interface Forum

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.