BIOS menu appearing instead of booting

When I try to start manjaro a menu appears… I think. So basically my pc lagged out during update had to kill it. When I attempted to start manj. later it did not work (not getting pass my pc brand logo). So I tried usb booting manjaro minimal version and running grub install and now when I start manj this BIOS appears, secure boot is off. For additional info just ask and ill tell u. This is the pic:

in the bios boot options is manjaro detected? if yes can you boot it?

thats the thing when I boot into it this screen appears like when I select it by hand in the boot menu

so manjaro is detected but when you try to boot it, you end up in bios?

I think its the BIOS… its the picture at the top

so boot again into manjaro usb, chroot and rerun update again:
pacman -Syu
if it went ok, we reinstall also grub and kernels just to be sure

I think I already tried running sudo pacman -Syu and I think it went fine but I can try again.

ok so rerun it again from chroot and then post output from:
test -d /sys/firmware/efi && echo efi || echo bios
mhwd-kernel -li

you mentioned above that you run from manjaro usb grub reinstall…
connect to internet in the live usb, and then chroot:
sudo manjaro-chroot -a
then rerun update:
pacman -Syu

How do u use chroot I’m a newbie. Completely forgot to mention I use dual boot with windows.

check post above

it looks like you chrooted normally …
dont need to run it with sudo in chroot… run it without it:
pacman -Syu
if it doesnt work, try this:
pamac update

don’t need sudo to chroot either.

manjaro-chroot -a

This seems like it’s what I’m looking for I hope itll work… I’ll try it.

Alr guys I tried different things none seem to work…

ive never seen this bus error, so googled it and not much, except something related to messed up hard drive, which could be your case too, since you had to force shutdown it during an update…
post output from:
lsblk -f

[manjaro /]# pacman update
Bus error (core dumped)
[manjaro /]# exit
 --> umount: [/mnt/boot/efi]
 --> umount: [/mnt]
    ~  lsblk -f                                                                       BUS ✘  33m 17s  
NAME  FSTYPE FSVER LABEL            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0 squash 4.0                                                               0   100% /run/miso/sfs/livefs
loop1 squash 4.0                                                               0   100% /run/miso/sfs/mhwdfs
loop2 squash 4.0                                                               0   100% /run/miso/sfs/desktopfs
loop3 squash 4.0                                                               0   100% /run/miso/sfs/rootfs
│     ntfs         WINRE_DRV        AE800CFD800CCDB1                                    
│     vfat   FAT32 SYSTEM_DRV       8C0D-E4E6                                           
│     ntfs         Windows8_OS      D2BE0F9DBE0F796D                                    
│     ext4   1.0                    01a339bf-1b65-42a9-adec-e0ab1d401eca                
      ntfs         Lenovo_Recovery  B6440AF1440AB3E1                                    
sdb   iso966 Jolie MANJARO_KDEM_2137
                                    2022-08-16-12-45-56-00                     0   100% /run/miso/bootmnt
│     iso966 Jolie MANJARO_KDEM_2137
│                                   2022-08-16-12-45-56-00                              
      vfat   FAT12 MISO_EFI         C08C-67BD                                           

edit your post and use formating - click this icon in editor: </> and copy the output there…
so run fsck on it, first unmount it:
sudo umount /dev/sda5
run fsck:
sudo fsck /dev/sda5