BIOS goes to black screen, touchpad click not working

Just Now I dual booted my laptop with Manjaro and it already have the windows 10 its in UEFI mode after installation I am facing couple of issues

  1. Whenever I try to enter to BOIS screen with F2 key I see only black screen with single dash(-) on display and nothing else happing.
  2. My touchpad is not working in Manjaro, arrow movement is working but click not working
  3. Whenever I start the laptop it directly boots to Windows, to go to Manjaro during startup I have to explicitly press the F12 key and then I can enter to Manjaro

can anyone please hep me with above issues

Hi @SEbitwar ,

Welcome to the forum, I wonder whether you could check you have properly installed Manjaro.
[root tip] Dual boot Manjaro and Windows

Also, you can provide the model of your laptop running the following terminal command and post the output following this guidelines:
inxi -Fazy

How to provide good information

Hope this help, regards

1 Like

Thanks for reply @j8a I solved all the issues after scrapping some searches below is the summery
1 and 3 → I had to save my BIOS to default settings via going through UEFI firmware settings option and then I added the added the Manjaro entry in add UEFI file as trusted for execution which solved the directly going to windows and BIOS black screen issue
2 → It was pretty straight forward I changed some setting in mouse and touch pad settings and it worked

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.