BIOS errors after system wake up

I have a desktop PC which is based on Intel i7-6850K on Gigabyte X99 UD4 v1.1. It have worked quite well for most of the time. Recently after system update I started experiencing wake up issues which are coming from bios.
To be fair I have no idea what does it mean. All I found in the internet in the topic was about disabling ACPI, but then I think I will loose sleep option entirely.

Attached picture with error:

ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT1.SPT1._FTF.DSSP], AE_NOT_FOUND (20210730/psargs-330)
ACPI Error: Aborting method \_SB.PCI0.SAT1.SPT1._GTF due to previous error (AE_NOT_FOUND) (20210730/psparse-529)

And so on. Anyone has any idea what this is about?

I’d focus on last line - your NIC. Throw it into google, maybe you can find something.

It was a good hint, I haven’t tracked this device, turns out to be wifi dongle which I had plugged in my box for a while. After removing it earlier errors stay. Sadly system resume is still not working.

try with different kernels

1 Like

This sounds obvious but update bios, if available that is…

I gonna give it a try. I am currently on kernel 5.15.55 as 5.16 was giving me some troubles with nvidia. I can try 5.4 and 5.10 and see if its any better. I haven’t tracked it but maybe I got a microcode update which did something. I have attempted to install latest ucode, but it haven’t made any difference.

I contacted Gigabyte to see if they will be willing to do anything about it. I doubt if they will cause X99 is nowhere close to recent specs. Latest bios is F23 which was released in 2017 and I been using for last 4 years.

Ok, I made it through on kernel 5.4 after reinstalling linux54-nvidia. That version of kernel was able to sleep and wake up. After reboot I was able to get proper behavior also under kernel 5.10.

BIOS warnings are still appearing but wake up works. So it might be that my BIOS was always emitting these and real problem is Kernel and its wake procedure. I will check if I will have any early traces in logs.