Biber Issue "Can't Locate in @INC..."

Hello, I’m pretty new to Manjaro and “nitty gritty” of Linux, so maybe I’m a bit unfamiliar with some basics. But I’m trying to user biber for LaTeX. I just installed texlive-full, and when I went to use biber for a file (ie my command was “biber example”), I got this:

“Can’t locate in @INC (you may need to install the PAR module) (@INC contains: /usr/local/perl/lib/site_perl/5.30.0/x86_64-linux-thread-multi /usr/local/perl/lib/site_perl/5.30.0 /usr/local/perl/lib/5.30.0/x86_64-linux-thread-multi /usr/local/perl/lib/5.30.0) at -e line 593.”

I dug around the web trying to find some solution, and none seemed to turn up. I then tried to straight install it, with “sudo pacman -S biber”, but this also failed. If I run “biber --cache”, for example, it gives me the same output. However, I can access the man page.

How should I go about fixing this?

edit: I have also tried installing PAR with “cpan install PAR”, and the result has not changed.

edit: if I unlink it from /usr/local/bin (link made by “sudo ln -s /opt/texlive/2020/bin/x86_64-linux/biber”), then even if I run “sudo pacman -S biber”, it tells me “bash: /usr/local/bin/biber: No such file or directory”. But it still gives me the man page for biber. If I relink it, it’s back to the same starting point.

edit: the man page was due to the biber package installed via pacman, not via texlive. I uninstalled biber package, and am running into same problem, except there is no man page.

POSSIBLE SOLUTION: I think things were out of sync. I uninstalled my original texlive-full. Then I ran the command

“sudo pacman -Syu elinks”


“sudo pacman -Sy texlive-most texlive-lang”

And it worked!

edit: I also had to do “sudo pacman -Sy biber”, and it’s all good.