BEHRINGER UMC202HD not seen as output device after 5.8 update

It was working on 5.7.14-1 still. using kde plasma, it only shows up as a Input device with either analog or digital options, no output options available atm.

Kind of a noob with issues like this, what steps should I take?

$ inxi -Fxxxza --no-host
System:    Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=6813d4d2-7b43-4c7e-98a1-fe1ec30d9387 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: X399 Taichi serial: <filter> UEFI [Legacy]: American Megatrends v: P3.80 
           date: 08/27/2019 
CPU:       Topology: 12-Core model: AMD Ryzen Threadripper 2920X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 
           stepping: 2 microcode: 800820D L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 167733 
           Speed: 2408 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz): 1: 2399 2: 1716 3: 1888 4: 2190 5: 2574 
           6: 1802 7: 1815 8: 1803 9: 2571 10: 1799 11: 2618 12: 2395 13: 1716 14: 1854 15: 2054 16: 2052 17: 2179 18: 1716 
           19: 2406 20: 1712 21: 2407 22: 2000 23: 1712 24: 1889 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 41:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu FAILED: ati unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5") 
           Monitor-1: DisplayPort-1 res: 1920x1080 hz: 60 dpi: 98 size: 497x292mm (19.6x11.5") diag: 576mm (22.7") 
           Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.38.0 5.8.0-2-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.5 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 chip ID: 1022:1457 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Sapphire Limited driver: snd_hda_intel 
           v: kernel bus ID: 41:00.1 chip ID: 1002:aaf0 
           Device-3: BEHRINGER UMC202HD 192k type: USB driver: snd-usb-audio bus ID: 1-2:2 chip ID: 1397:0507 
           Sound Server: ALSA v: k5.8.0-2-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.6.0-k port: 2000 bus ID: 04:00.0 
           chip ID: 8086:1539 
           IF: enp4s0 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: 2000 bus ID: 05:00.0 
           chip ID: 8086:24fb 
           IF: wlp5s0 state: up mac: <filter> 
           Device-3: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.6.0-k port: 1000 bus ID: 06:00.0 
           chip ID: 8086:1539 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 7.28 TiB used: 1.59 TiB (21.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: MBR 
           ID-3: /dev/sdc vendor: Western Digital model: WD10EADS-00P8B0 size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 0A01 scheme: MBR 
           ID-4: /dev/sdd vendor: Western Digital model: WD60EFRX-68MYMN1 size: 5.46 TiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5700 rpm serial: <filter> rev: 0A82 scheme: GPT 
Partition: ID-1: / raw size: 465.76 GiB size: 457.45 GiB (98.22%) used: 274.47 GiB (60.0%) fs: ext4 dev: /dev/sdb1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 29.5 C mobo: 29.0 C gpu: amdgpu temp: 36 C 
           Fan Speeds (RPM): fan-1: 929 fan-2: 2106 fan-3: 934 fan-4: 0 fan-5: 714 gpu: amdgpu fan: 909 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.28 
Info:      Processes: 454 Uptime: 15m Memory: 31.22 GiB used: 2.85 GiB (9.1%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           clang: 10.0.1 Packages: 1535 pacman: 1531 lib: 393 flatpak: 0 snap: 4 Shell: Bash v: 5.0.18 running in: konsole 
           inxi: 3.1.05

$ pacmd dump
### Configuration dump generated at Mon Aug 17 14:04:50 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="2" name="usb-BEHRINGER_UMC202HD_192k-00" card_name="alsa_card.usb-BEHRINGER_UMC202HD_192k-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_41_00.1" card_name="alsa_card.pci-0000_41_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0
load-module module-x11-xsmp display=:0 session_manager=local/AndorDesktop:@/tmp/.ICE-unix/1833,unix/AndorDesktop:/tmp/.ICE-unix/1833
load-module module-alsa-card device_id="0" name="pci-0000_09_00.3" card_name="alsa_card.pci-0000_09_00.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2 0xc28f
set-sink-mute alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2 no
suspend-sink alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2 yes
set-sink-volume alsa_output.pci-0000_09_00.3.iec958-stereo 0x7d71
set-sink-mute alsa_output.pci-0000_09_00.3.iec958-stereo no
suspend-sink alsa_output.pci-0000_09_00.3.iec958-stereo yes

set-source-volume alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2.monitor 0x10000
set-source-mute alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2.monitor no
suspend-source alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2.monitor yes
set-source-volume alsa_output.pci-0000_09_00.3.iec958-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_09_00.3.iec958-stereo.monitor no
suspend-source alsa_output.pci-0000_09_00.3.iec958-stereo.monitor yes
set-source-volume alsa_input.usb-BEHRINGER_UMC202HD_192k-00.analog-stereo 0x14ccd
set-source-mute alsa_input.usb-BEHRINGER_UMC202HD_192k-00.analog-stereo no
suspend-source alsa_input.usb-BEHRINGER_UMC202HD_192k-00.analog-stereo yes

set-card-profile alsa_card.usb-BEHRINGER_UMC202HD_192k-00 input:analog-stereo
set-card-profile alsa_card.pci-0000_41_00.1 output:hdmi-stereo-extra2
set-card-profile alsa_card.pci-0000_09_00.3 output:iec958-stereo

set-default-sink alsa_output.pci-0000_09_00.3.iec958-stereo
set-default-source alsa_input.usb-BEHRINGER_UMC202HD_192k-00.analog-stereo

### EOF

Edit: It seems that certain programs can still use its output; Mixxx for example still can while Discord cannot see the output.

pacmd dump shows USB device Profile is set for audio input only

set-card-profile alsa_card.usb-BEHRINGER_UMC202HD_192k-00 input:analog-stereo

please post response to

pacmd list-cards

to show if a working Profile is available for audio input + output

Following is the response:

$ pacmd list-cards
3 card(s) available.
    index: 0
        name: <alsa_card.usb-BEHRINGER_UMC202HD_192k-00>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "2"
                alsa.card_name = "UMC202HD 192k"
                alsa.long_card_name = "BEHRINGER UMC202HD 192k at usb-0000:01:00.0-2, high speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:01:00.0-usb-0:2:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:01.1/0000:01:00.0/usb1/1-2/1-2:1.0/sound/card2"
                udev.id = "usb-BEHRINGER_UMC202HD_192k-00"
                device.bus = "usb"
                device.vendor.id = "1397"
                device.vendor.name = "BEHRINGER International GmbH"
                device.product.id = "0507"
                device.product.name = "UMC202HD 192k"
                device.serial = "BEHRINGER_UMC202HD_192k"
                device.string = "2"
                device.description = "UMC202HD 192k"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-usb"
        profiles:
                input:analog-stereo: Analoog stereo Input (priority 65, available: unknown)
                input:iec958-stereo: Digitaal stereo (IEC958) Input (priority 55, available: unknown)
                off: Uit (priority 0, available: unknown)
        active profile: <input:analog-stereo>
        sources:
                alsa_input.usb-BEHRINGER_UMC202HD_192k-00.analog-stereo/#4: UMC202HD 192k Analoog stereo
        ports:
                analog-input-mic: Microfoon (priority 8700, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

    index: 1
        name: <alsa_card.pci-0000_41_00.1>
        driver: <module-alsa-card.c>
        owner module: 7
        properties:
                alsa.card = "1"
                alsa.card_name = "HDA ATI HDMI"
                alsa.long_card_name = "HDA ATI HDMI at 0x9f760000 irq 84"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:41:00.1"
                sysfs.path = "/devices/pci0000:40/0000:40:01.3/0000:41:00.1/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1002"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                device.product.id = "aaf0"
                device.product.name = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
                device.string = "1"
                device.description = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
                output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
                output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: unknown)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
                output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: unknown)
                off: Uit (priority 0, available: unknown)
        active profile: <output:hdmi-stereo-extra2>
        sinks:
                alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2/#0: Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 3)
        sources:
                alsa_output.pci-0000_41_00.1.hdmi-stereo-extra2.monitor/#1: Monitor of Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 3)
        ports:
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "PLX2783H"
                hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "HP E221c"
    index: 2
        name: <alsa_card.pci-0000_09_00.3>
        driver: <module-alsa-card.c>
        owner module: 29
        properties:
                alsa.card = "0"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xba700000 irq 82"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:09:00.3"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:09:00.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "1457"
                device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
                device.string = "0"
                device.description = "Family 17h (Models 00h-0fh) HD Audio Controller"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analoog stereo Input (priority 65, available: no)
                output:analog-stereo: Analoog stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:analog-stereo: Analoog stereo duplex (priority 6565, available: no)
                output:analog-surround-21: Analoog surround 2.1 Output (priority 1300, available: no)
                output:analog-surround-21+input:analog-stereo: Analoog surround 2.1 Output + Analoog stereo Input (priority 1365, available: no)
                output:analog-surround-40: Analoog surround 4.0 Output (priority 1200, available: no)
                output:analog-surround-40+input:analog-stereo: Analoog surround 4.0 Output + Analoog stereo Input (priority 1265, available: no)
                output:analog-surround-41: Analoog surround 4.1 Output (priority 1300, available: no)
                output:analog-surround-41+input:analog-stereo: Analoog surround 4.1 Output + Analoog stereo Input (priority 1365, available: no)
                output:analog-surround-50: Analoog surround 5.0 Output (priority 1200, available: no)
                output:analog-surround-50+input:analog-stereo: Analoog surround 5.0 Output + Analoog stereo Input (priority 1265, available: no)
                output:analog-surround-51: Analoog surround 5.1 Output (priority 1300, available: no)
                output:analog-surround-51+input:analog-stereo: Analoog surround 5.1 Output + Analoog stereo Input (priority 1365, available: no)
                output:iec958-stereo: Digitaal stereo (IEC958) Output (priority 5500, available: unknown)
                output:iec958-stereo+input:analog-stereo: Digitaal stereo (IEC958) Output + Analoog stereo Input (priority 5565, available: no)
                off: Uit (priority 0, available: unknown)
        active profile: <output:analog-stereo>
        sinks:
                alsa_output.pci-0000_09_00.3.analog-stereo/#2: Family 17h (Models 00h-0fh) HD Audio Controller Analoog stereo
        sources:
                alsa_output.pci-0000_09_00.3.analog-stereo.monitor/#5: Monitor of Family 17h (Models 00h-0fh) HD Audio Controller Analoog stereo
        ports:
                analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-linein: Lijn-in (priority 8100, latency offset 0 usec, available: no)
                        properties:

                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
                        properties:

                analog-output-headphones: Analoge koptelefoon (priority 9900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "audio-headphones"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

i expected to see more than 3 profiles for USB device:

  • input:analog-stereo
  • input:iec958-stereo
  • off

no profile to support audio playback

audio played using Mixxx would be direct to ALSA and not using Pulseaudio

please post reponse to

aplay -l && amixer --card=2

Response:

$ aplay -l && amixer --card=2
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: U192k [UMC202HD 192k], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 127
  Front Left: Capture 127 [100%] [0.00dB] [on]
  Front Right: Capture 127 [100%] [0.00dB] [on]
Simple mixer control 'Mic',1
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 127
  Mono: Capture 127 [100%] [0.00dB] [on]
Simple mixer control 'UMC202HD 192k Output',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'UMC202HD 192k Output',1
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]

playback device is present in ALSA

card 2: U192k [UMC202HD 192k], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and turned on

Simple mixer control 'UMC202HD 192k Output',0

  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]

so should be detected in Pulseaudio

suggest clear Pulseaudio user preferences and settings and reboot system

mv ~/.config/pulse/ ~/.config/pulse.old && reboot

mv ~/.config/pulse/ ~/.config/pulse.old && reboot

No change with the audio device yet after command and reboot.

Im a bit at a loss here at the moment, I tried reinstalling Pulseaudio but this didnt work.

I also tried launching manjaro with kernel 5.7.14-1 and 5.4.57-1 to see if i could rollback and use the soundcard then. But It remains undetected as output.

Not really sure where to go from here.

Edit: It seems that ‘pulseaudio -k’ makes it work with output again for the session atleast.