Beep sound on 'Log out..." dialog

When I click on the “Log out…” button in the whiskers menu - there’s a short chirping sound / beep. How to turn it off?

I don’t have a physical pc speaker. And I also blacklisted the suggested modules:

# cat /etc/modprobe.d/nobeep.conf
blacklist pcspkr
blacklist snd_pcsp

Any other solution?

I’m using pipewire.

xset -b

PC speaker - Xorg - ArchWiki

@nikgnomic Tried xset -b too… does not help.

Probably more a crackling or popping? Take a look here: PipeWire - ArchWiki

No, not a crackling - it’s a clean sound, a beep. The same sound as if in the terminal you type:

echo ^G # ctrl-v ctrl-g

Definitely it’s the dialog that starts the sound, but I don’t know where to turn it off.

On windows you had a sound scheme setting - where you could turn off all sounds. I don’ know if there’s an equivalent.

BTW: I noticed the same sound is played if you press backspace in the search field of the whiskers menu (start menu).

maybe something to do with libpipewire-x11-bell ?

Well yes could be.

@samo_dadela Does your “beep sound” sound like this file on your system?


If so, then @nikgnomic is correct here.

  1. You can mute “System Sounds” in pavucontrol
  2. Disable it in xfce4-appearance-settings under “Settings” → “Event Sounds” (Re-login then)
  3. Completely remove it from pipewire:
    1. pamac remove pipewire-x11-bell
    2. systemctl --user restart pipewire

@megavolt Yes, that’s the sound.

xfce4-appearance-settingsSettingsEnable event sounds was already unchecked, so that’s not it.

Mute "System Sounds in pavucontrol works, though.
I did not mute it, but lowered the volume so it’s not that bothersome - even better than turning it off completely.

Mistery solved! Thanks to everybody.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.