BCM4360 connection stops working (but is not dropped) randomly

Have this issue for months, but can’t solve it. My only option is to use wired PowerLine connection, which isn’t as fast as WiFi, so I’d like to finally fix it. Here’s the issue:

Manjaro KDE with Asus PCE-AC68 PCI-E adapter (based on BCM4360). Adapter works out of the box, but connection stos responding randomly. It NEVER displays “Disconnected” message, but just displays 0.00 kb/s and connection doesn’t work (can’t even connect to router). Sometimes it comes back a few minutes later, sometimes I have to manually disconnect and re-connect again. Happens totally randomly - sometimes just twice a day, sometimes every several minutes.

After lots of search I found BCM4360 causes lots if issues, but unlike all other people, I never had a single problem with adapter itself not being listed and/or WiFi connection not being found. It finds and establishes connections just fine. Just randomly stops working… Tried different kernel versions, no lock, so using 5.4.80 LTS now.

inxi -F                                                                                                                                                                                                                                                                                                              
System:    Host: desktop Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF B450-PLUS GAMING v: Rev X.0x serial: <superuser/root required> 
           UEFI: American Megatrends v: 2409 date: 12/02/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 4003 MHz min/max: 2200/4000 MHz Core speeds (MHz): 1: 4000 2: 4001 3: 3997 4: 4014 5: 4000 6: 4009 7: 4000 
           8: 4041 9: 4000 10: 4000 11: 4027 12: 4012 
Graphics:  Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 455.45.01 
           Display: x11 server: X.Org 1.20.10 driver: nvidia s-res: 2560x1440 
           OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
Audio:     Device-1: NVIDIA GP108 High Definition Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.80-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:b3:6e:c2 
           Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter driver: wl 
           IF: wlan0 state: up mac: 04:d9:f5:8b:43:ea 
Drives:    Local Storage: total: 1.14 TiB used: 243.56 GiB (20.8%) 
           ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD size: 238.47 GiB 
           ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
           ID-3: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
RAID:      Device-1: md0 type: mdraid status: active raid: mirror report: 2/2 UU Components: online: sdb1~c1 sda1~c0 
Partition: ID-1: / size: 233.23 GiB used: 12.59 GiB (5.4%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 498.0 MiB used: 58.2 MiB (11.7%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 40.4 C mobo: N/A gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 315 Uptime: 45m Memory: 15.55 GiB used: 2.71 GiB (17.4%) Shell: Zsh inxi: 3.1.08

lspci -k
08:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 85df
        Kernel driver in use: wl
        Kernel modules: bcma, wl

A thing that looks strange to me is that adapter is detected and works fine, but has no option to install any drivers via Hardware Configuration - https://i.postimg.cc/rwNLj2h4/network.png

mhwd -li                                                                                                                                                                                                                                                                                                             
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI
    video-nvidia-455xx            2020.10.04               false            PCI

Got these packages installed:

  • linux54-broadcom-wl
  • b43-fwcutter
  • manjaro-firmware

Some old posts on these forums (and Arch forums) suggest installing b43-firmware package, but if I try to do so, installer says it conflicts with manjaro-firmware. In addition, b43-firmware was modified in 2015 last time, so I guess manjaro-firmware is all I need?

Any suggestions?

Hello @toxpal :wink:

Could be possible that this is the channel issue when using 5Ghz ?


You may restrict the available channels for 5Ghz in router… or just only use 2.4Ghz and disable 5Ghz.

1 Like

You should check (and post) the vendor:device ID’s of your Wifi Chipset/adapter…

Honestly, I saw that entry in wiki before, but ignored it. Not sure why… Well, changed the channel and will see what happens next.

Disabling 5 GHz and only using 2.4 GHz is not the best option because I have 600 mbps connection (sure, I can’t achieve such speed in real life, but I get about 500 mbps with SpeedTest), so 5 GHz is a must for me.

Do you mean this?

lspci -nn
08:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

Keep in mind that 5GHz is way more sensitive wrt obstacles like walls, way more as 2.4GHz…
So if you have (most likely) walls and/or floor(s) between you and your modem, that will be the main factor for the bad connection…

Yes, I absolutely understand it. However, there’s another Manjaro KDE PC one floor above (but it has a different ASUS adapter), and it works without any problems. Will try to bring that PC to my workroom (where problem occurs) to see if connection issues happen on both PCs or only one.

So the issue seems to be solved (no problems for 3 days). It looks the issue was related to 5 GHz channel. Once 5 GHz channel was manually changed to 40, everything works fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.