Battlefield 1 Steam-Proton DirectX Error

A few months to a year ago I had installed and played battlefield 1. I decided to play again, and I’m getting an error. “DirectX Error - Failed to initialize display adaptor. … blah blah compatible… blah blah vendor specific drivers” :smiley:

After some trouble shooting with I was able to get it to load the menus using: PROTON_USE_WINED3D=1 %command%

However, when I went to play a game, all I could see was really wild hot pink screen with a ridiculous rainbow shiny gun (I coudn’t see anything essentially)

~ >>> inxi -F
System: Host: karen-main-game Kernel: 5.10.52-1-MANJARO x86_64 bits: 64 Desktop: GNOME 40.3 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASRock model: X99 Taichi serial: UEFI: American Megatrends v: P1.80
date: 04/06/2018
CPU: Info: 6-Core model: Intel Core i7-5930K bits: 64 type: MT MCP cache: L2: 15 MiB
Speed: 1237 MHz min/max: 1200/3700 MHz Core speeds (MHz): 1: 1237 2: 1197 3: 1197 4: 2364 5: 1197 6: 1197 7: 1197
8: 2640 9: 1677 10: 1197 11: 1197 12: 1197
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz
OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.40.0 5.10.52-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.1.5
Audio: Device-1: Intel C610/X99 series HD Audio driver: snd_hda_intel
Device-2: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel
Device-3: JMTek LLC. Gaming Headset type: USB driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.10.52-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Sound Server-3: PipeWire v: 0.3.32 running: yes
Network: Device-1: Intel Ethernet I218-V driver: e1000e
IF: enp0s25 state: up speed: 1000 Mbps duplex: full
Device-2: Intel Wireless 3160 driver: iwlwifi
IF: wlp7s0 state: down
Drives: Local Storage: total: 4.55 TiB used: 3.29 TiB (72.4%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB
ID-2: /dev/sda vendor: Western Digital model: WD4001FAEX-00MJRA0 size: 3.64 TiB
Partition: ID-1: / size: 915.6 GiB used: 683.38 GiB (74.6%) fs: ext4 dev: /dev/dm-0
ID-2: /boot/efi size: 299.4 MiB used: 424 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap: Alert: No swap data was found.
Sensors: System Temperatures: cpu: 29.0 C mobo: N/A gpu: amdgpu temp: 30.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 712
Info: Processes: 385 Uptime: 3d 2h 22m Memory: 31.28 GiB used: 5.7 GiB (18.2%) Shell: Zsh inxi: 3.3.06

~ >>> vkmark -p immediate [127]

  • WARNING: Unknown option RADV_PERFTEST=‘aco’. ACO is enabled by default now. *

vkmark 2017.08

Vendor ID:      0x1002
Device ID:      0x687F
Device Name:    Radeon RX Vega
Driver Version: 8388791
Device UUID:    c5825a0f421c51f886c2a4a9738ace46

[vertex] device-local=true: FPS: 15829 FrameTime: 0.063 ms
[vertex] device-local=false: FPS: 9382 FrameTime: 0.107 ms
[texture] anisotropy=0: FPS: 15214 FrameTime: 0.066 ms
[texture] anisotropy=16: FPS: 15223 FrameTime: 0.066 ms
[shading] shading=gouraud: FPS: 15283 FrameTime: 0.065 ms
[shading] shading=blinn-phong-inf: FPS: 15184 FrameTime: 0.066 ms
[shading] shading=phong: FPS: 15074 FrameTime: 0.066 ms
[shading] shading=cel: FPS: 15096 FrameTime: 0.066 ms
[effect2d] kernel=edge: FPS: 15298 FrameTime: 0.065 ms
[effect2d] kernel=blur: FPS: 12940 FrameTime: 0.077 ms
[desktop] : FPS: 12756 FrameTime: 0.078 ms
[cube] : FPS: 17518 FrameTime: 0.057 ms
[clear] : FPS: 17407 FrameTime: 0.057 ms

                               vkmark Score: 14784


Xorg/X11 wayland both produce the same error.

It is 100% a problem with proton/wine/dxvk, since your system works as expected.

Which versions of proton did you try? You can force steam to use a specifc version.

i tried experimental and 6.3-5