fails to load fails to load from time to time with the error

This application failed to start because it could not find or load the Qt platform plugin "windows" in "".

This seems to be a common error. For me what fixes it is the following:

Go into the subdirectory with the latest version number, go to the platform directory and run

setfattr -x user.DOSATTRIB qwindows.dll

This sets some extended file attribute and makes it work. What does this specific attribute do and why is it important in this specific case?

1 Like
setfattr --help
setfattr 2.5.1 -- set extended attributes
Usage: setfattr {-n name} [-v value] [-h] file...
       setfattr {-x name} [-h] file...
  -n, --name=name         set the value of the named extended attribute
  -x, --remove=name       remove the named extended attribute
  -v, --value=value       use value as the attribute value
  -h, --no-dereference    do not dereference symbolic links
      --restore=file      restore extended attributes
      --raw               attribute value is not encoded
      --version           print version and exit
      --help              this help text

the command removes some attribute which I know nothing about :man_shrugging:

Seeing it is a Micro$@$/Mac only app, it might be related to what you use to run it :thinking:
If you use Lutris maybe you should visit their forum to mention what you describe.
Same incase you use Steam…

I have no idea cause i don’t use Your app :woman_shrugging:

Yes, it is a windows app which I run through wine. Sorry forgot to mention it.

I actually got the solution from this reddit post.

The reddit post is quite hard to find among all the other search results.

EDIT: reported the bug to wine here.

I can confirm that it worked on my machine as well.

At the moment doesn’t work at all for me. If I want to play Starcraft II, I need to launch it directly.