Battery Threshold Settings

I did set a treshold for my battery charging limit using Kde Plasma GUI.
It applied on system default settings and now, whatever I tried, I cannot change this.
I did reset BIOS settings, tried to use TLPUI but nothing changed. Please Help.
I am using Thinkpad E14 Gen 2

What do you mean? Does show an error? Does it simply ignore your desired value? Can you change it using for example echo 100 | sudo tee /sys/class/power_supply/BAT*/charge_stop_threshold?

There is no error but yes it is ignore my new value.
And in the TLPUI my “STOP_CHARGE_THRESH_BAT0” default value is 80 and “START_CHARGE_THRESH_BAT0” default value is 75. I tried to assign new values and other things but nothing changed. My battery level can’t pass above %79

I tried echo 100 | sudo tee /sys/class/power_supply/BAT*/charge_stop_threshold but nothing changed

I reboot my system after wrote this code and: Battery percentage starts to decrease but in the TLPUI default value is still the same

What’s the output of sudo tlp-stat -b ?

sudo tlp-stat -b
— TLP 1.1 --------------------------------------------

+++ ThinkPad Battery Features
tp-smapi = inactive (kernel module ‘tp_smapi’ not installed)
tpacpi-bat = inactive (kernel module ‘acpi_call’ not installed)

+++ Battery Status
/sys/class/power_supply/BAT0/manufacturer = Celxpert
/sys/class/power_supply/BAT0/model_name = 5B10X026
/sys/class/power_supply/BAT0/cycle_count = 3
/sys/class/power_supply/BAT0/energy_full_design = 45000 [mWh]
/sys/class/power_supply/BAT0/energy_full = 45000 [mWh]
/sys/class/power_supply/BAT0/energy_now = 41150 [mWh]
/sys/class/power_supply/BAT0/power_now = 16825 [mW]
/sys/class/power_supply/BAT0/status = Charging

Charge = 91.4 [%]
Capacity = 100.0 [%]

You’re missing the appropriate kernel module.

Do you know how to install these?

Yes, read

Then install the right one with your package manager.

And why do you have TLP 1.1, last version is TLP 1.3.

I know nothing about KDE tools for Thinkpad battery management, but it will probably conflict with TLP. So if your TLP settings don’t stick, you will know why.

If upgrade TLP, I think you won’t have to install any extra kernel modules since that version should support a newer kernel interface that lets you change the charging thresholds. And yes, TLP and PowerDevil will probably conflict in certain cases. And TLPUI always shows the thresholds that are configured for TLP, not the current, actual ones.

Here is my new “sudo tlp-stat -b” output:
sudo tlp-stat -b
[sudo] password for cagr:
— TLP 1.3.1 --------------------------------------------

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi = active (data, thresholds)
tpacpi-bat = active (recalibrate)
tp-smapi = inactive (ThinkPad not supported)

+++ ThinkPad Battery Status: BAT0 (Main / Internal)
/sys/class/power_supply/BAT0/manufacturer = Celxpert
/sys/class/power_supply/BAT0/model_name = 5B10X026
/sys/class/power_supply/BAT0/cycle_count = 3
/sys/class/power_supply/BAT0/energy_full_design = 45000 [mWh]
/sys/class/power_supply/BAT0/energy_full = 45000 [mWh]
/sys/class/power_supply/BAT0/energy_now = 44430 [mWh]
/sys/class/power_supply/BAT0/power_now = 5541 [mW]
/sys/class/power_supply/BAT0/status = Charging

/sys/class/power_supply/BAT0/charge_start_threshold = 95 [%]
/sys/class/power_supply/BAT0/charge_stop_threshold = 100 [%]
tpacpi-bat.BAT0.forceDischarge = 0

Charge = 98.7 [%]
Capacity = 100.0 [%]

Is that means, whatever tlpui says, my current treshold settings are %95 and %100 and there is no more system default setting for treshold like %75 and %80?

I’m not a KDE user and I can’t help you further, you’re using two differents tools which probably conflict. I just thought about the TLP kernel module because I had to do it on my Thinkpad.

Good luck :slight_smile:

I’m not sure what you mean. This means that TLP can now set the battery charge thresholds. This will probably conflict with PowerDevil: so only use either PowerDevil, or TLP to set the thresholds, not both.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.