Battery Threshold On Lenovo V130

I’m on Manjaro KDE and I’d like to limit the battery charging threshold.
My laptop is Lenovo V130
and I have tried tlp but no luck.
I’m kinda noob so, will give any other info if needed.
Thank you for your reply and time in advance.

  1. The easy solution is to set the battery charging levels in Windows and then reboot.

  2. The more difficult approach is to ensure the TLP service is enabled:

    sudo sytemctl enable tlp

    and then RTFM and set your ThinkPad specific settings in TLP. :slight_smile:

Also, for the future, please read this:


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

Thank you @Fabby for you reply.
I’m sorry, I’ll add the info right now.
Tlp didnt work and im not on dual boot currently

 Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
 Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 81HN v: Lenovo V130-15IKB 
  serial: <filter> Chassis: type: 10 v: Lenovo V130-15IKB serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: 8VCN17WW date: 05/02/2019 
  ID-1: BAT0 charge: 22.0 Wh condition: 30.5/30.6 Wh (100%) volts: 7.8/7.6 
  model: CPT-COS L17C2PB3 type: Li-poly serial: <filter> status: Discharging 
  RAM: total: 7.12 GiB used: 2.81 GiB (39.4%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 6144 KiB bogomips: 28808 
  Speed: 948 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 900 2: 901 
  3: 900 4: 900 5: 900 6: 900 7: 901 8: 901 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-5:3 chip ID: 04ca:7070 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: amdgpu,intel FAILED: ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.6 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.4.60-2-MANJARO 
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: efa0 bus ID: 02:00.0 chip ID: 8086:3166 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: c000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 1.13 TiB used: 42.55 GiB (3.7%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LCM2 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WDS240G2G0B-00EPW0 
  size: 223.58 GiB speed: 6.0 Gb/s serial: <filter> rev: 0000 scheme: GPT 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD-RW DA8AESH rev: XL6M 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r state: running 
  Message: No RAID data was found. 
  ID-1: / size: 210.11 GiB used: 42.18 GiB (20.1%) fs: ext4 dev: /dev/sdb2 
  label: N/A uuid: 5e8adfe5-574a-4645-aa11-241e3d75faed 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/sdb1 label: N/A uuid: 99E8-AC6A 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 385.0 MiB (4.3%) 
  priority: -2 dev: /dev/sdb3 label: N/A 
  uuid: 141c0d1a-02fb-4946-9d37-d63fe7566fc7 
  ID-1: /dev/sda1 size: 232.83 GiB fs: ext4 label: HDD.Part1 Bkps 
  uuid: 6ba795dc-2154-4b2e-bb88-3e55ebd23235 
  ID-2: /dev/sda2 size: 7.45 GiB fs: swap label: swap 
  uuid: d7488ea0-db70-4f68-9f0e-e35530a0c752 
  ID-3: /dev/sda3 size: 465.85 GiB fs: ntfs label: HDD.Part3 Personal 
  uuid: 1A306D1F34155F53 
  ID-4: /dev/sda4 size: 225.38 GiB fs: ext4 label: HDD.Part4 PCBkp 
  uuid: 12032873-a888-4fbb-b4da-f5c523b559b4 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-1:2 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 25a7:fa23 
  Device-2: 1-5:3 info: Lite-On Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04ca:7070 
  Device-3: 1-8:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0a2a 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 50.0 C mobo: 45.0 C gpu: amdgpu temp: 49 C 
  Fan Speeds (RPM): N/A 
  Processes: 243 Uptime: 3h 30m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: 1295 pacman: 1291 snap: 4 Shell: Bash v: 5.0.18 
  running in: konsole inxi: 3.1.05

If sudo sytemctl enable tlp gave you the following error:

Failed to enable unit: Unit file tlp.service does not exist

you need to install it first:

pamac install tlp

then go back to #2 above.


I have installed tlp and seen, it doesnt work… battery thresholds dont hold

What’s the output of sudo tlp-stat -b?

1 Like

It says, the battery isnt supported… So, is there any other work around then?

Well, one thing you could try is sudo modprobe thinkpad_acpi, and if it succeeds (meaning it prints nothing), check sudo tlp-stat -b again.

1 Like
--- TLP 1.3.1 --------------------------------------------

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi    = inactive (laptop not supported)
tpacpi-bat = inactive (laptop not supported)
tp-smapi   = inactive (laptop not supported)

+++ Battery Status: BAT0
/sys/class/power_supply/BAT0/manufacturer                   = CPT-COS
/sys/class/power_supply/BAT0/model_name                     = L17C2PB3
/sys/class/power_supply/BAT0/cycle_count                    = (not supported)
/sys/class/power_supply/BAT0/energy_full_design             =  30630 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  29960 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =  26180 [mWh]
/sys/class/power_supply/BAT0/power_now                      =   7379 [mW]
/sys/class/power_supply/BAT0/status                         = Discharging

Charge                                                      =   87.4 [%]
Capacity                                                    =   97.8 [%]

I tried, still same thing

I’m in the same case as you and that’s how companies sell more batteries:

sudo tlp-stat --battery

--- TLP 1.3.1 --------------------------------------------

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi    = inactive (laptop not supported)
tpacpi-bat = inactive (laptop not supported)
tp-smapi   = inactive (laptop not supported)

Defective by design…


Sad, that this happened :’’’(((

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.