Battery maximum charge dropping

For the past couple of weeks my laptop says fully charged before reaching the 100% of charge. What worries me is that last week it displayed 98% and in a few days it went to 96% and now it’s 94%. The laptop is a Lenovo Thinkpad E580 which is barely one year old.

I have read here that this could be normal behavior but I don’t know how to be sure. I’m just worried because it keeps dropping. Since I’ve installed Manjaro Gnome some months ago I asked the question here because it might be related to it.

Here it is my inxi -F

  Host: espectro-estranho Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 
  Desktop: GNOME 40.3 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20KS0039PG v: ThinkPad E580 
  serial: <superuser required> 
  Mobo: LENOVO model: 20KS0039PG v: SDK0J40697 WIN 
  serial: <superuser required> UEFI: LENOVO v: R0PET47W (1.24 ) 
  date: 08/29/2018 
  ID-1: BAT0 charge: 39.2 Wh (94.9%) condition: 41.3/45.7 Wh (90.2%) 
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP cache: 
  L2: 8 MiB 
  Speed: 2761 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 2761 2: 2784 
  3: 2741 4: 2704 5: 2786 6: 2732 7: 2800 8: 2743 
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] 
  driver: amdgpu v: kernel 
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  Display: wayland server: 1.20.13 driver: loaded: amdgpu,ati,intel 
  unloaded: modesetting resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.6 
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp3s0 state: down mac: e8:6a:64:5d:67:6e 
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  IF: wlp5s0 state: up mac: 1c:1b:b5:90:55:a1 
  Local Storage: total: 1.14 TiB used: 167.53 GiB (14.3%) 
  ID-1: /dev/nvme0n1 vendor: Lenovo model: LENSE30256GMSP34MEAT3TA 
  size: 238.47 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  ID-1: / size: 48.83 GiB used: 32.73 GiB (67.0%) fs: btrfs 
  dev: /dev/nvme0n1p3 
  ID-2: /boot/efi size: 511 MiB used: 568 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-3: /home size: 184.16 GiB used: 134.8 GiB (73.2%) fs: btrfs 
  dev: /dev/nvme0n1p4 
  ID-4: /var/log size: 48.83 GiB used: 32.73 GiB (67.0%) fs: btrfs 
  dev: /dev/nvme0n1p3 
  ID-1: swap-1 type: partition size: 4.98 GiB used: 0 KiB (0.0%) 
  dev: /dev/nvme0n1p2 
  System Temperatures: cpu: 46.0 C mobo: 0.0 C gpu: amdgpu temp: 39.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 309 Uptime: 41m Memory: 7.54 GiB used: 3.64 GiB (48.3%) 
  Shell: Zsh inxi: 3.3.06

What do you think about this?

If you run it continuously via the power supply, this behavior is normal to protect the battery.
Just let it run empty to 0%, then the battery will be fully charged again.

1 Like

I will try that just to check it. Thank you :smiley: . If this behavior functions to protect the battery it means that there is no problem in running it continuously via the power supply. I mean as far as the normal degeneration of a battery goes.

i don’t know if it’s normal behavior, what’s decreasing over time is the battery health.
in kde with a Lenovo pc, there is a function to set the charge limit,which is good for the battery health.

If it is normal behavior it should be encoded in the hardware itself because I don’t think I have messed around with any power settings. I’m running Gnome and I don’t think there are any such option, @linub .

I’ll report back here when I finish testing @DerTodesengel88 proposition.

If anyone has any further ideas feel free to post them.

In any case, I have this behavior with Gnome on my Lenovo IdeaPad.
A few weeks in continuous operation (i.e. with a power supply unit) the charge level decreased every day. Standard is now always 60% for me.
With TLP, it should be possible to configure this limit differently. However, it is such a good setting as the default.

1 Like

Thanks @DerTodesengel88 for your insight. I discharged my ThinkPad and now it stabilized at 99%. Since yours has the same behavior I’m more reassured :grinning_face_with_smiling_eyes:. Thank you everyone.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.