Battery Life drops about 75% when initializing Audio System

I recently found that whenever my Audio System is initialized by starting Apps like Ardour or even pavucontrol the remaining battery life immediatly heavy drops from e.g. 20 to 5 hours…?
That seems way to much to me.
I tried different kernels, switched from pulse to pipewire, but the issue persists.

CPU: 8-core AMD Ryzen 9 7940HS w/ Radeon 780M Graphics (-MT MCP-)
speed/min/max: 470/400/5263:5423:5583:6228:5743:5903:6067 MHz
Kernel: 6.6.5-2-MANJARO x86_64 Up: 21m Mem: 1.74/14.85 GiB (11.7%)
Storage: 953.87 GiB (3.7% used) Procs: 340 Shell: Zsh 5.9 inxi: 3.3.31

  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_pci_ps v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.5-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off with: nsmd status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl

Maybe I should try another distro to see if its Manjaro/Arch issue…

Have you seen a higher CPU usage after the said apps have been started (e.g. in HTOP)?
Did you connect or use other power consuming devices (micros, speakers etc.)?

HTOP showing 0% CPU usage. I use an external Monitor on HDMI. USB Hub and USB Keyboard and Mouse…not really power consuming.
The laptop/hardware is quiet new (released May 2023). Maybe the hardware is not yet fully supported in Linux?

Battery life in ‘remaining hours’ has nothing to do with real battery status, which would be Wh or mAh if you want. So, either the first (20 h) or the second (5 h) is simply a wrong prognosis about it, if your CPU usage (or GPU usage, or energy usage of any other devices) has not increased.

Check output of

inxi -Bza
  ID-1: BAT0 charge: 25.7 Wh (50.6%) condition: 50.8/50.0 Wh (101.5%)
    power: 2.3 W volts: 11.5 min: 11.9 model: ASUSTeK ASUS Battery type: Li-ion
    serial: N/A status: discharging cycles: 33

So did the battery capacity change after starting the app(s)?

If not then the only remaining question would be - does starting the app(s) really discharge the battery faster than if they won’t be started.

The capacity did not change immediatly, but discharging is faster, even if I run pavucontrol. And I have to correct me…HTOP showing higher CPU usage. Normally 1% battery lasts for about 10 Minutes. If I run pavucontrol than maybe for 3 Minutes.

What processes?
And - is it lasting or only for a short period of time?
Have you Bluetooth devices connected?

It’s lasting, no bluetooth (disabled in Bios)

Even CPUPower-gui showing higher CPU usage compared to idle.


Is a browser running in parallel? If yes, close it and verify CPU usage again.

No Browser running. Just checked the issue with different Live Distros (Linux Mint, Linux Mint Debian, Cachy OS) Same issue everywhere. As soon as starting/initializing Sound System (Pavucontrol, Ardour, Audacity) battery life heavy drops/drains, discharging up to 75 % faster.

Checked with my old Acer Laptop with 4 Core Intel Celeron CPU.
No such issue with Ardour, or Audacity. Battery % remains constant. No heavy drain.
Though pavucontrol causes 25% CPU usage.
So it seems hardware related to AMD APU. So maybe this ASUS Laptop is too new for Linux, or some kind of hardware fault…No Windows OS here, so I could check there.
And I cant remember if this issue was there from beginning or came with an update.

In this pulseaudio bug report some suggestions are provided, maybe you wish to try.

Could be, but also could simply require different, non-standard settings in config files.

EDIT: The high CPU usage and battery drain of pavucontrol went away if I untick “show volume meters” in pavucontrol Configuration.


The issue is not really solved, because it persists on my Asus/AMD Hardware e.g when running Ardour.

Have you tried to enable ‘Stop Plugins on Transport Stop’ in the preferences (Under Plug-Ins/General)?


I can’t find this setting.

Maybe it’s “Neue Plugins sind aktiv”
I tried to untick → no change

PulseAudio has module-suspend-on-idle that suspends idle sinks and sources after a predetermined time (default = 8 seconds) to save power
But if pavucontrol is open, devices are not considered idle and are not suspended

Unused sinks and sources can be suspended (or set card Profile to ‘off’) to improve battery life

Internal speakers usually need more power from system than headphones or externally powered speakers