Batman arkham city not running on amd

i have installed batman arkham city on steam but not running on amd gpu(deticated gpu).

my system information:

  Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4-x86_64 
  root=UUID=65bb43f0-0913-47ec-ad3b-72e35f09034d rw rootflags=subvol=@ 
  quiet apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A 
  serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.13.0 
  date: 08/13/2020 
  ID-1: BAT0 charge: 18.5 Wh condition: 18.5/41.4 Wh (45%) 
  volts: 17.0/14.8 model: SMP DELL VN3N047 type: Li-ion serial: <filter> 
  status: Full 
  Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: DE 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 21607 
  Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 799 2: 792 
  3: 800 4: 786 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / 
  Radeon 520 Mobile] 
  vendor: Dell driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 
  chip ID: 1002:6660 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:3 chip ID: 0bda:5769 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: ati,intel,radeon unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.4.80-2-MANJARO 
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
  bus ID: 02:00.0 chip ID: 8086:3165 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8136 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 931.51 GiB used: 320.41 GiB (34.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM3 
  scheme: GPT 
  ID-1: / raw size: 120.00 GiB size: 120.00 GiB (100.00%) 
  used: 26.00 GiB (21.7%) fs: btrfs dev: /dev/sda2 
  ID-2: /home raw size: 811.01 GiB size: 811.01 GiB (100.00%) 
  used: 294.41 GiB (36.3%) fs: btrfs dev: /dev/sda3 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.0 C mobo: 46.0 C gpu: radeon temp: 43.0 C 
  Fan Speeds (RPM): cpu: 2549 
  Processes: 214 Uptime: 30m Memory: 7.65 GiB used: 1.46 GiB (19.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1321 pacman: 1319 
  lib: 365 flatpak: 0 snap: 2 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08

and I have tried launching the game using “DRI_PRIME=1” and added “DRI_PRIME=1%command%” to “SET LAUNCH OPTIONS…” in steam

output for "DRI_PRIME=1 glxinfo | grep “OpenGL renderer” :

OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 5.4.80-2-MANJARO, LLVM 11.0.0

running radeontop while playing Batman arkham city:

no usage of AMD gpu while playing the game, but while playing Saints row IV the usage is showing, but not like the batman arkham city game.

i need the game to run on deticated gpu is because iam facing performence problem, in this game.

Is this LITERALLY what you wrote in Steam?

i have tried it but not working, I have added it to the “SET LAUNCH OPTIONS…” in steam games.

I mean it is missing a space before %command%

sorry! but i tried with space too “DRI_PRIME=1 %command%”, not working