Basic: app icons positioning

After I upgraded (now I have pinephone - plasma-mobile - 20210306, 6.0.3-1-MANJARO-ARM) all the app icons moved to the right, leaving an indication to “Add applications to your favourites so they show up here.” How do I do that?

In addition, there are waydroid applications and native ones. How do I distinguish them? I can list waydroid apps, but the names on the icons differ. I would, at least, position them after the waydroid icon. Is it possible to do that?

BTW, what is the exact meaning of the three bottom buttons, □, ⋅>, X. My guess: X closes the active app, sometimes ⋅> seems to do the same, □ does nothing.

The default homescreen Folio was replaced by Halcyon in Plasma Mobile 5.26. See “Homescreen” under Plasma Mobile Gear ⚙ 22.09 is Out - Plasma Mobile. (Note that, as briefly mentioned in that announcement, the Plasma Mobile shell is actually released with Plasma, not with the Plasma Mobile Gear.)

To switch back:

In Folio, I do a long press and move (i.e., I do not release the finger after the long press, but drag the icon) to the favorites. Not sure whether that also works in Halcyon, I am still using Folio.

  • □ shows the window switcher if you have multiple windows open, so you can switch from one window to the other. (They are normally all maximized, so you can only see one at a time, unless you are in the window switcher.)
  • What you call ⋅>, i.e., the Plasma logo, shows the homescreen, i.e., it hides all the applications. It does not close them. Use the window switcher (see above) to go back to the application.
  • × indeed closes the current window, i.e., usually, the current application. (Some applications, mostly GTK applications, can also have modal dialogs, where the × button only closes the dialog and not the entire application. Plasma Mobile applications normally use layers instead of dialog windows, so closing the dialog layer is done within the application and not through the bottom bar. In that case, × always closes the entire application.)
1 Like

Thanks, that helps.

It doesn’t work. The long press shows two choices, Change Wallpaper and Configure. Neither works. Choosing Configure brings me to a blank screen entitled Wallpaper. Choosing Change Wallpaper shows a little rectangle half wallpaper and half black, non-interactive.

If I run plasma-settings or plasma-open-settings from an ssh terminal they just close. I have to run them as root. Probably I should run them from the phone’s terminal, but I just killed it in an attempt to switch to qmlkonsole. Grr…