Baloo still crashing

Happens after installing the most recent updates:

[Sat Dec 24 17:45:13 2022] traps: baloo_file_extr[965] general protection fault ip:7fadd157a154 sp:7ffdeb
375948 error:0 in[7fadd156e000+10000]

I found the same problem reported on this forum: Baloo_file keeps crashing. balloo_file and ballosearch behaviour is exactly the same as in that 2-year old post:

~  baloo_file                                                                       ✔  base  
kf.baloo: "/home/george/Documents/llvmlite/docs/source/glossary.rst" id seems to have changed. Perhaps baloo was not running, and this file was deleted + re-created
~  baloosearch 2022-12-20                                                           ✔  base  
Elapsed: 0.241545 msecs

I have never used baloo before, recall seeing crash reports on Fedora in the past. Is there anything that I should try?

Give this a go:

balooctl disable && balooctl purge && balooctl enable

Check status next with balooctl status

Worked, sort of:

/mnt/sdb1/home/george/Documents  balooctl status                                    ✔  base  
kf.i18n: KLocalizedString: Using an empty domain, fix the code. msgid: "Unknown" msgid_plural: "" msgctxt: ""
kf.i18n: KLocalizedString: Using an empty domain, fix the code. msgid: "Indexing file content" msgid_plural: "" msgctxt: ""
Baloo File Indexer is running
Indexer state: Indexing file content
Total files indexed: 362,381
Files waiting for content indexing: 308,193
Files failed to index: 0
Current size of index is 233.57 MiB

In the window I ran the commands I am getting a lot of errors about files:

"Error: Invalid least number of objects reading page offset hints table"
"Error: Invalid Font Weight"
"Error: Invalid Font Weight"
Invalid encoding. Ignoring "/home/george/Downloads/archlinux-2022.11.01-x86_64.iso.torrent"
Invalid encoding. Ignoring "/home/george/Downloads/archlinux-2022.11.01-x86_64.iso.sig"
Invalid encoding. Ignoring "/home/george/cyxy/dsk3/mosaic/arwc/warning.arwc.html"
Invalid encoding. Ignoring "/home/george/cyxy/dsk3/mosaic/arwc/bak/warning.arwc.html.bak"
Invalid encoding. Ignoring "/home/george/cyxy/dsk3/mosaic/arwc/bak/wrng.htm.bak"

I’ve been monitoring baloo’s memory usage on one of my machines. It’s higher than normal, consuming 50% of all my desktop computer has to offer in non-idle time, plus CPU usage has become heavier somehow. There is a possibility it is, indeed, a bug, but I’vnt seen any new ticket opened yet.

Hi yt87,

i had some issues with baloo as well. What caused it for me was some large folders that were not to be indexed missing from the excluded folders list. (In my case my timeshift backups folder)

You can check for excluded folders in your baloo config. I used

balooctl config list excludeFolders

to get this list. In my case the folder for my timeshift backup folder was not in the excluded folders list, which let to baloo constantly indexing my timeshift backups and keeping it busy all the time up to freezing up my Laptop for a few seconds every few minutes. Maybe that can help you too…

Best regards


I had no issues since the index file was recreated 3 weeks ago.
For a fun, I restored the old index file from backup and started baloo. It started crashing again:

[Sat Jan 14 23:35:26 2023] traps: baloo_file_extr[89915] general protection fault ip:7f6c028d2154 sp:7ffdfc77edf8 error:0 in[7f6c028c6000+10000]
[Sat Jan 14 23:35:36 2023] traps: baloo_file_extr[89935] general protection fault ip:7ff05f46a154 sp:7ffdf3ffe2e8 error:0 in[7ff05f45e000+10000]

So, it seems the database was corrupted.
Happily indexing files again. Thanks for all responses.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.