Baloo indexing high CPU and memory usage when idle

Hi there. baloo_file_extractor uses 3.0 GB of memory when it is idle as shown below:


Sometimes it can use up to 5 GB of RAM and over 10% of CPU.

This was never met and makes the computer very laggy and slow. Can anyone help? Thanks a lot!

Hi @CarrotDLaw,

Baloo can be slow and a resource hog, yes.

I suggest you change your settings in System SettingsWorkspaceSearchFile Search to not include file contents or hidden files/folders.

Like mine:

Then delete the index and rebuild it. So stop and disable baloo:

balooctl stop
balooctl disable

Then remove the current index:

rm -fr .local/share/baloo

Enable baloo again:

balooctl enable

Make doubly sure the index is empty:

balooctl purge

And re-index it all:

balooctl check

If you want to check the status of baloo, use:

balooctl status

For example:

$ balooctl status
Baloo File Indexer is running
Indexer state: Idle
Total files indexed: 36 527
Files waiting for content indexing: 0
Files failed to index: 0
Current size of index is 17,35 MiB

Hope this helps!

Edit:

On the same settings screen of System Settings there is also the option to include/exclude specific directories. I have my music and my Cloud drive mounts listed there.

1 Like

Thanks for your help! Now, I think I meet another problem. I disabled baloo and removed the current index, but it seems to continue using high CPU and RAM. If I want to completely disable baloo, what should I do?

It’ll continue to do so after you’ve done it all because it needs to reindex everything. So it’ll be better after a while.

If, however, you want to completely disable it permanently, you can do the follwing:

balooctl stop
balooctl disable

Or, that’s how I understand it anyway.

Edit:
But leaving it enabled has its good sides. So just be patient a bit.

Yes! From balooctl status, it is disabled and not running. But from the system monitor, it is still using a lot of RAM and my computer is still laggy. I don’t know how to tackle this.

Reboot and see if it persists. Report back.

Also see Baloo - KDE Community Wiki

Also Baloo - ArchWiki


From that article:

Disabling the indexer

To disable the Baloo file indexer:

balooctl suspend
balooctl disable

The indexer will be disabled on next login.

Alternatively, disable Enable File Search in System settings under Search > File search.

To permanently delete the index database, run:

balooctl purge

Thank you so much! Everything works fine now. Sorry for not reading the wiki before asking.

You are very welcome!

Always check the wiki first. It is extremely helpful! And you might see something that’s never crossed your mind before.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.