Baloo freezes system

Starting today, I’m also experiencing the same bug where the system freezes, but mouse cursor still responds. However, my issue isn’t “periodic”. It happens EVERY time a few minutes after boot. I usually don’t have much time to investigate before everything freezes.

Trying to open another tty with Control+Alt+F2 goes to black screen, but no prompt appears.

Turning off manually with the power button is the only way to make it respond, and then it corrupts the hard drive, and the BIOS/UEFI must run a disk check before the bootloader will load. Otherwise, it won’t even boot.

CPU: i7-9700
GPU: nvidia 1660 ti
Kernel: 5.18.15 or 5.15.57 both don’t work

In your case it’s probably just Baloo doing its indexing, and you can disable that. Do a search here on the forum because this has been discussed a gazillion times already.

What the OP is reporting appears to be a very different issue — potentially related to the graphics driver, but I’m not sure.

1 Like

Baloo has caused slowdowns, but it’s never completely froze everything and corrupted the disk when powered off. Disabling it does seem to fix the issue. Thank you.

Searching this forum for “kde freeze” didn’t result in my exact symptoms; most users’ freezes were described as short and they usually were able to reboot, so this thread seemed like the closest.

Searching for “baloo freeze” doesn’t return much info about how to solve the issue besides just to disable it. Do you have some link references on how to fix the underlying issue? Oh well, I suppose I can use alternate file search programs in any case. Thanks again.

It’s the unclean powering-off that corrupts the filesystem, not Baloo. :wink:

You can tweak what Baloo indexes.

Most commonly — and possibly in the newest install media for the Plasma edition of Manjaro, but I do not know — Baloo indexes the whole drive, both in terms of the filenames and in terms of the file content. On my own system, I have it set up to only index the filenames but not the file content, and I am also explicitly telling it which directories to index and which directories to skip.


  • I have split this thread off from the other one because intentionally or not, you were essentially hijacking somebody else’s thread, and that other person’s issue doesn’t have anything to do with Baloo.

  • Considering that your problem was solved by my suggestion to disable Baloo, I have marked post #2 as the solution. Should you disagree with that choice, then you may always designate another post as the solution if it provides for a better answer to your problem.

1 Like

Thanks for the response and tip. The split and solution are fine. Sorry about the thread hijack.

I just wish I could narrow down the problem directories/files without risking corruption. When it locks up and I’m forced to power down, the following boot fails to blank screen with no bootloader, which is very unnerving, and it takes a while before UEFI prompts for diagnostics.

1 Like

I think it’s probably wisest to exclude /boot, /var, /usr, /opt and /tmp, and to let it index only the filenames, not the file content.

Also bear in mind that anything being indexed on an NTFS filesystem may cause problems as well, due to the fundamental differences between Microsoft Windows and the way it handles file content on the one hand, and UNIX on the other hand. But this I don’t really know, because I don’t use Microsoft Windows and I don’t have any Windows filesystems.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.