Bad quality when conference call through ms teams, facebook messager or google meets; but recording (through applications or browsers) works flawlessly

Hi guys, i am using manjaro xfce with kernel 5.10.49-1 LTS. my computer is acer aspire e15. my microphone, whenever i joined a video call or a conference call online , it will create a fan-like noises like a fan points straight into the microphone. it creates echo sound multiple times until it got high pitch which is unbearable.

I dont think this problem is related to hardware because when i use recording using web browsers or applications it worked flawlessly (still the built-in microphone).

Can anyone help me to debug and find the root cause of this problem? I dont know where to start. (I have follow all the guide from archWiki, including settings like echo/noise cancellation and stuff)

That is confusing:

So how do you join a call, when not using the webrowser or an application?

recording and online call are 2 different thing. I pointed that out because they both use microphone, which means it’s not a hardware problem.

I can only assume that you are in fact using two different microphones. You said you are using something like noise cancelling and other effects which may create a virtual microphone that is used for the recording applications but not the chat applications.

Ah thanks… i misunderstand that.

That happens at least for when you gain the volume in pulseaudio over the base. That seems to be normal. On WebRTC which is used in webbrowsers and electron apps, there must be an option to use echo cancellation and noise reduction.

However with pulseaudio it should be done with:

pactl load-module module-echo-cancel source_name=virtual_mic source_properties=device.description=virtual_mic

Now there should be a another virtual mic which uses echo cancellation and it should also do noise reduction. For permanent:

Copy the default config to your home folder:

cp /etc/pulse/ ~/.config/pulse/

and add there at the bottom:

load-module module-echo-cancel source_name=virtual_mic source_properties=device.description=virtual_mic

Now it should load the module on every boot.

Thanks for your help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.