Bad performance on latest Manjaro KDE

  Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=919153cc-3d54-43f5-b7c3-d0ad3c64aa25 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: MSI model: H110M GAMING (MS-7994) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 5.B0 date: 06/25/2018 
  Message: No system battery data found. Is one present? 
  RAM: total: 15.59 GiB used: 3.06 GiB (19.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-7600K bits: 64 type: MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  cache: L2: 6 MiB bogomips: 30409 
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: Micro-Star MSI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:2484 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 91 s-size: 1070x301mm (42.1x11.9") 
  s-diag: 1112mm (43.8") 
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 92 size: 530x300mm (20.9x11.8") 
  diag: 609mm (24") 
  Monitor-2: DP-0 res: 1920x1080 dpi: 94 size: 521x293mm (20.5x11.5") 
  diag: 598mm (23.5") 
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
  chip-ID: 8086:a170 class-ID: 0403 
  Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:228b 
  class-ID: 0403 
  Device-3: FiiO FiiO K5 Pro type: USB driver: snd-usb-audio bus-ID: 1-3:4 
  chip-ID: 2972:0047 class-ID: fe01 
  Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: kernel port: f000 bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 168c:0032 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 5.69 TiB used: 28.88 GiB (0.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-00MFCA0 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 QVO 1TB 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 2B6Q scheme: GPT 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 3B6Q scheme: GPT 
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: Seagate 
  model: ST2000LM007-1R8174 size: 1.82 TiB block-size: physical: 4096 B 
  logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1153 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 195.31 GiB size: 191.24 GiB (97.92%) 
  used: 28.86 GiB (15.1%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A 
  uuid: 919153cc-3d54-43f5-b7c3-d0ad3c64aa25 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 24.7 MiB (25.8%) fs: vfat dev: /dev/sdd2 maj-min: 8:50 label: N/A 
  uuid: 26CF-67AF 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 19.53 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdc4 maj-min: 8:36 label: N/A 
  uuid: 0fe19c94-8570-4b74-b4b5-a313939a568a 
  ID-1: /dev/sda1 maj-min: 8:1 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/sda2 maj-min: 8:2 size: 1.82 TiB fs: ntfs label: MEGA DRIVE 
  uuid: 0AA2F6D0A2F6BEEF 
  ID-3: /dev/sdb1 maj-min: 8:17 size: 931.51 GiB fs: ntfs 
  label: Demons&Diamonds uuid: 60C8CA8FC8CA62C0 
  ID-4: /dev/sdc1 maj-min: 8:33 size: 540.89 GiB fs: ntfs label: Red Barron 
  uuid: 78C34FCD60F0479A 
  ID-5: /dev/sdc3 maj-min: 8:35 size: 19.53 GiB fs: ext4 label: N/A 
  uuid: c99bfcc0-6cec-419d-a021-2b354655300c 
  ID-6: /dev/sdd1 maj-min: 8:49 size: 499 MiB fs: ntfs label: Recovery 
  uuid: 989ECDAB9ECD81EC 
  ID-7: /dev/sdd3 maj-min: 8:51 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-8: /dev/sdd4 maj-min: 8:52 size: 232.28 GiB fs: ntfs 
  label: Carpenter Brut uuid: E8084186084154AA 
  ID-9: /dev/sde1 maj-min: 8:65 size: 1.82 TiB fs: exfat label: Le Perv 
  uuid: 3852-7900 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:3 info: Logitech G502 Proteus Spectrum Optical Mouse 
  type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 300mA chip-ID: 046d:c332 class-ID: 0300 
  serial: <filter> 
  Device-2: 1-3:4 info: FiiO FiiO K5 Pro type: Audio driver: snd-usb-audio 
  interfaces: 3 rev: 2.0 speed: 480 Mb/s chip-ID: 2972:0047 class-ID: fe01 
  Device-3: 1-4:5 info: Corsair Gaming K70 LUX RGB Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 1b1c:1b33 class-ID: 0300 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 2-4:2 info: LaCie P9227 Slim type: Mass Storage driver: uas 
  interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 896mA chip-ID: 059f:1090 
  class-ID: 0806 serial: <filter> 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 31.5 C mobo: 29.8 C gpu: nvidia temp: 32 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 213 Uptime: 1h 43m wakeups: 1 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1289 
  lib: 400 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.06 


  1. Videos and other some media in browser in 1440p and up are lagging notably more than in Win 10
    I’m not sure what could be done here. Probably lack of hardware acceleration.

  1. The only driver that worked was from Nvidia. Trying to run Manjaro with open source drivers, before install and after, lead to black screen with one line of some text and numbers.
    I’ve tried to launch DE from there, had no success, and I’m not even sure if I need to switch drivers.

Apologies for grammar mistakes and unclear questions, English is not my first and I didn’t know anything about Linux less than a week ago.

Edit 1
Thank you Fabby for your answer!

I’ve reinstalled system completely because I broke everything, making it unusable after switching to Wayland after X11 tweaks. Overall performance and stability is better now, still not perfect for me.

I will be trying to set up Wayland with Manjaro 21.1.0 that just came out, independently of this system, which at least I haven’t broke :sweat_smile:

Edit 2
All previous issues with system performance has been fixed by switching to XRender and adding these environmental variables


The problem was because of dual monitor setup with different refresh rates 144hz and 60hz the whole system was stuck with 60fps, and XRender works much better than any OpenGL for whatever reason.

For Firefox I’ve done a full reset and videos and everything else seems to run much better than before, still not flawlessly tho.

For open source drivers I’m giving up because there is no point in them since Nvidia is working good enough.

For Kernel I’ve set up newer version to see if there any performance changes, and it seems to be working fine.
The only thing I’ve noticed is that sometimes some applications just have black space in their window instead of GUI, but it is fixable by minimizing them or reopening. I don’t know if Kernel has to do anything with screen rendering to be honest, I will try 5.4 later and see how it goes.

Thank you for Swap information, I’ve set it up.
And thank you for everything else, I will probably see this post in couple of years and feel nostalgic that I didn’t know anything and you helped me :slightly_smiling_face:

1 Like

Kernel 5.12 is EOL so please install both 5.4 and 5.10 LTS (Long Time Support) and see which one of the two troubles you least.

Please read this

Start there already and then see if the problems go away automagically


1 Like