Backlight service not working and the amdgpu_bl1 is masked

Hey there!
I switched to manjaro about a month ago as my first linux distro and things have been going pretty well except for this backlight issue I have had since the very beginning.

So when i first booted into manjaro it used to show me this:

Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video1.

I went through the wiki, the forum and many guides but nothing really worked
but today I changed my /etc/default/grub like this:


then updated grub and rebooted. Then, the black screen popped up without the backlight error but in a green text saying the service was loaded.
But even after that It wasn’t fixed, I use bspwm and xfce and changing the brightness in either of them is not working

I thought it was a problem with my backlight service so I did:

systemctl status systemd-backlight@amdgpu_bl1.service

also apparently most people have amdgpu_bl0 and I don’t know if that makes any difference but do please educate me about this.

So well after i checked the status it showed me this:

○ systemd-backlight@amdgpu_bl1.service
     Loaded: masked (Reason: Unit systemd-backlight@amdgpu_bl1.service is masked.)
     Active: inactive (dead)

I tried unmasking the service with:

systemctl unmask systemd-backlight@amdgpu_bl1.service 

and did a systemctl daemon-reload and rebooted, still didn’t work.
I am having problems with unmasking this service and I believe this is what causes the problem with my brightness but as you can probably already tell, I am a noob so do please educate me about this.
Device: Lenovo Ideapad Gaming 15ARH05
CPU: Ryzen 5 4600H
GPU: AMD radeon graphics with Nvidia Gtx 1650
Kernel: 5.14.10-1

I’ve found that moving to kernel 515-rt solves the adjustment issue most of the time. Not the saving of backlight values though.