Backlight (Brightness) stops working altogether on kernel 5.8

Booting from kernel linux58 breaks my ability to control brightness: at all. It gets stuck on the highest brightness. I can move the slider and enter xbacklight commands, but it stays on full brightness. In contract, when booted with kernel linux54, brightness control continues to work.

I have tried changing the usual boot parameter variants, to no avail. The ones I tried are:

Below is my full inxi -f report in case it helps.

System:    Host: manjaro-2019 Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 Desktop: GNOME 3.36.6 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: iMac18,3 v: 1.0 serial: <superuser/root required> 
           Mobo: Apple model: Mac-BE088AF8C5EB4FA2 v: iMac18,3 serial: <superuser/root required> UEFI: Apple 
           v: date: 01/31/2020 
CPU:       Topology: Quad Core model: Intel Core i5-7500 bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
           v: kernel 
           Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting,vesa resolution: 2560x1440~60Hz 
           OpenGL: renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.35.0 5.4.64-1-MANJARO LLVM 10.0.1) 
           v: 4.6 Mesa 20.1.7 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel 
           Device-3: USB type: USB driver: snd-usb-audio,usbhid 
           Device-4: VIA USB2.1 Hub type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.4.64-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM43602 802.11ac Wireless LAN SoC driver: brcmfmac 
           IF: wlp3s0 state: up mac:  
           Device-2: Broadcom and subsidiaries NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3 
           IF: enp4s0f0 state: down mac:  
           IF-ID-1: docker0 state: down mac:  
           IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 957.59 GiB used: 525.06 GiB (54.8%) 
           ID-1: /dev/nvme0n1 vendor: Apple model: SSD SM0032L size: 26.08 GiB 
           ID-2: /dev/sda vendor: Apple model: HDD ST1000DM003 size: 931.51 GiB 
Partition: ID-1: / size: 91.17 GiB used: 34.60 GiB (38.0%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 453.9 MiB used: 177.2 MiB (39.1%) fs: ext4 dev: /dev/sda6 
Swap:      ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A gpu: amdgpu temp: 48 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 298 Uptime: 10m Memory: 7.68 GiB used: 2.58 GiB (33.6%) Shell: Bash inxi: 3.1.05

Do you have anything in /sys/class/backlight/?

Yes, thanks.

ls /sys/class/backlight/
acpi_video0 amdgpu_bl0

In both of those directories, there should be a brightness and max_brightness file. What happens if you write half of max_brightness into brightness for each of them?

$ cat max_brightness
$ echo 12000 | sudo tee brightness

Appreciate the suggestion. I need to reboot into the 5.8 kernel to test. On the 5.4 kernel, in the acpi_video directory, the tee command decreases/increases brightness.

Ok, I tested those commands on the 5.8 kernel for both the directories. Nothing happens to the brightness of the screen when issuing the commands. The only change is that the brightness slider on the menu bar goes to the spot on the slider that corresponds to the number I chose. So, for example:

cd /sys/class/backlight/acpi_video0
echo 5 | sudo tee brightness

Results in the slider toward the left hand side.

Do you have a compelling reason to have kernel 5.8 installed (E.G. some piece of hardware doesn’t work on 5.4???)

If yes: try 5.9 RC6
If no: Well, that’s why Manjaro provides multiple kernel versions and kernel version management becomes a thing. Clap along if you feel like happiness is the truth and stay on 5.4, unless something doesn’t work and then try out newer kernel versions as they become available until it does work.


1 Like

Yeah, the audio does not work on late model iMacs. I’m always trying to use the latest kernels to see if it fixes the audio. 5.8 does not. But I try each as they come out.

Not sure why I should accept that new kernels won’t work for brightness though. I’ve been running Linux on iMacs for about 10 years and it is par for the course to have to tweak the boot parameters to get the backlight to work properly. So I see this as a part of the process.

On my iMac12,1 (21.5" 2011) with kernel 5.9 and 5.10, I encountered the same problem.

With acpi_backlight=video option or absent, there exists /sys/class/backlight/acpi_video0.

Either vendor or native causes the empty /sys/class/backlight/.

System always boots with default brightness 3 (of 15/max_brightness). Probably it was set in macOS before i installed Manjaro. But the brightness will increase highest after suspend.

The Plasma brightness widget can change the value of /sys/class/backlight/acpi_video0/brightness without any effect.

Many posts I googled suggested the kernel param acpi_backlight=<value> to present /sys/class/backlight/radeon_bl0. Maybe it only works with kernel 5.4?

I have an old 2011 I can test on in a few weeks. But for my 2019, backlight only works with kernel 5.4 (my kernel parameters are: radeon.dpm=0 acpi_osi=Darwin acpi_backlight=video).

Were you ever able to find a solution to the brightness or sound?
Im on 1 2015 imac running kernel 5.10.The sound works sometimes.It starts and stops on my machine and I cant determine whats triggering the change.
As for the backlight/brightness that has never worked.It seems to stay on 100.I guess that beats 0.

Yes, backlight works perfectly with the kernel 5.10.53-1-MANJARO and the following boot parameters: acpi_osi=!Darwin radeon.dpm=0 acpi_backlight=video.

I have never been able to get sound – ever – on the Linux side of the 2019 iMac; it only works if I boot into OSX.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.