B43 driver seems to be installed, but no place to check "enable wifi" in new install?


I’ve been running a Manjaro partition for quite awhile in my '12 desktop with ethernet connection, more or less w/o issue. Today I ran a fresh install of Manjaro using ethernet on my '09 Mac Book Pro and it went quickly and system booted up.

After rebooting and upgrading I find no place in Network Manager to “enable wifi”?? I looked at a few threads and saw one where “b43” was mentioned. I checked “lsmod” and I see it mentioned in a few places, but when I disconnected ethernet, wifi doesn’t take over??

What else would I need, or need to do to get wifi enabled??

Other concurrent issue, compared to the Leap 15.5 install I had in the machine before this new install, Manjaro seems to have the fan blowing rather loudly?? I know historically some linux distros don’t seem to do Mac temperature control too well, but I’d like the machine to be quieter on the use of fan, if possible??? Anything to adjust to get that to happen??

Most likely as always you need the wl driver on mac and blacklist all other related kernel drivers. On Manjaro you can install it like that:

sudo mhwd -i network-broadcom-wl

mhwd also creates the blacklist.

1 Like

I’m on a 2009 mbp 5,4:

  Kernel: 5.10.164-1-MANJARO arch: x86_64 bits: 64 Desktop: MATE v: 1.26.0
    Distro: Manjaro Linux
  Type: Laptop System: Apple product: MacBookPro5,4 v: 1.0
    serial: <superuser required>
  Mobo: Apple model: Mac-F22587A1 v: MacBookPro5,4
    serial: <superuser required> UEFI: Apple v: MBP53.88Z.00AC.B03.0906151647
    date: 06/15/09
  ID-1: BAT0 charge: 78.2 Wh (100.0%) condition: 78.2/77.8 Wh (100.6%)
  Info: dual core model: Intel Core2 Duo P8700 bits: 64 type: MCP cache:
    L2: 3 MiB
  Speed (MHz): avg: 1282 min/max: 798/2527 cores: 1: 1563 2: 1002
  Device-1: NVIDIA C79 [GeForce 9400M] driver: nvidia v: 340.108
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7 driver: N/A
    resolution: 1440x900~60Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel
  Sound API: ALSA v: k5.10.164-1-MANJARO running: yes
  Sound Server-1: PipeWire v: 0.3.64 running: yes
  Device-1: NVIDIA MCP79 Ethernet driver: forcedeth
  IF: enp0s10 state: down mac: <filter>
  Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN
    driver: b43-pci-bridge
  IF-ID-1: wlan0 state: up mac: <filter>
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 111.79 GiB used: 47.8 GiB (42.8%)
  ID-1: /dev/sda vendor: Crucial model: CT120M500SSD3 size: 111.79 GiB
  ID-1: / size: 85.87 GiB used: 47.8 GiB (55.7%) fs: ext4 dev: /dev/sda3
  ID-2: /boot/efi size: 511 MiB used: 3.7 MiB (0.7%) fs: vfat dev: /dev/sda1
  ID-1: swap-1 type: partition size: 3.95 GiB used: 0 KiB (0.0%)
    dev: /dev/sda5
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A
  Processes: 254 Uptime: 5d 6h 50m Memory: 7.52 GiB used: 2.41 GiB (32.0%)
  Shell: Zsh inxi: 3.3.24

B43 works, How to enable Broadcom Wireless on Manjaro

It’s probably the open source nouveau driver if it’s the nvidia mbp. What desktop are you using? Avoid gnome, kde and cinnamon, install xfce or mate. Stay with 5.4 and 5.10 LTS kernels.

1 Like


Sorry, didn’t get an email notification on replies, so thanks for the data about “wl” . . . and glad to hear someone else is still running an 09 MBP . . . actually a very nice machine, especially with an Samsung EVO SSD and . . . Crucial RAM.

Stuff to do this morning, but I’ll check into it in a day or so . . . precerate it.


The linked instructions you provided seemed to be promising, ran through some of the commands, but it gets murky around here:

But that's not all. We need to add a module loading option under /etc/modprobe.d. This is similar to what we did with the Realtek Wireless card to make it work on older 3.X kernels. You need to create a configuration file with the following format: "module name".conf. In this case, b43.conf. Inside this file, we need the allhwsupport option:

options b43 allhwsupport=1

I tried to nano into the /etc/modprobe.d . . . but they dont show how to add the “b43.conf” name/title . . . and where to add in the “options b43 allsupport=1” data. When I nano’d into /etc/modprobe.d it shows in red letters, “this is a directory” and it shows something like “new buffer” . . . so what is the “new buffer”??? I can follow detailed instructions, but when it goes, “like we did it with the Realtek situation” . . . I get lost asap.

sudo modprobe -r wl
[sudo] password for n: 
modprobe: FATAL: Module wl not found.

[n-macbookpro54 ~]$ sudo modprobe b43
[n-macbookpro54 ~]$ sudo modprobe b43 allhwsupport=1
[n-macbookpro54 ~]$ sudo nano /etc/modules-load.d/modules.conf

[n-macbookpro54 ~]$ sudo cat /etc/modprobe.d/b43.conf
cat: /etc/modprobe.d/b43.conf: No such file or directory

[n-macbookpro54 ~]$ sudo nano /etc/modprobe.d
[n-macbookpro54 ~]$ sudo cat /etc/modprobe.d
cat: /etc/modprobe.d: Is a directory
[n-macbookpro54 ~]$ sudo nano /etc/modprobe.d

This is a MATE DE install . . . haven’t messed with the kernels.

Mine’s mate too.

My etc/modules-load.d/modules.conf looks like this:

# List of modules to load at boot

Create it. My /etc/modprobe.d/b43.conf looks like this:

options b43 allhwsupport=1

OK, well, that is what I am asking, how is that being “created”??? I see that I would be “naming” it something “b43.conf” and I would be adding that “options” into it.

I can do nanoing into a file and edit what is there, but the “creating” is escaping my mind or memory right now, old guy syndrome . . . I can’t remember if I know or ever knew, or never knew. Hence the request for help on it.

Do it in the caja file browser. Right click on the etc/modprobe.d directory, pick ‘open as administrator’. Do a right click in the new ‘modprobe.d (as superuser)’ window, pick ‘create Document’ >> ‘Empy File’, name it ‘b43.conf’, copy the line
options b43 allhwsupport=1
in it and ‘Save’.

1 Like

Thanks for that, I got as far as right-click in caja, but I didn’t have the option of “open as administrator” . . . . I just have “open” and when I right-click in that window “create Document” is greyed out, no “empty file” option . . . . I had “open in terminal” but is that what you mean??

I’m closer, but, still so far . . . .

sudo nano /etc/modprobe.d/b43.conf

It (nano) is an editor that you start in a terminal - quite easy to figure out.
A file with that name is created in that directory …

Perhaps try it first with some other file in your Home directory and without sudo
to get a feel of how to operate it.

nano ~/mytestfile
write something
save and quit
then open the editor again, with the same command - you see what you just wrote

1 Like

To get the ‘open as admin’ option install the caja-gksu package.

1 Like

OK. well I have used nano before, just not for “creating” . . . but did that and added the “options” data into it.

Rebooted. and no wifi options. Shut down and cold booted . . . still nothing in network manager to tick to get wifi going???

Historically there would be a “enable wifi” option to click??

I don’t know.
I was just prompted to tell you how to create/write to that file.

Did you check whether it is really there?
cat /etc/modprobe.d/b43.conf
should print the contents of that file

The icon for NetworkManager is in the panel (I guess)
a right click opens the context menu to check the boxes to enable/disable it.

That is all I know - I know nothing about your wifi driver.

No worries. Yes I did “cat” that and it showed the data.

Did you add
to etc/modules-load.d/modules.conf?

Also check ‘/etc/modprobe.d/blacklist.conf’ doesn’t have ‘b43’ blacklisted.

Did add the b43 and it shows “blacklisted.conf” doesn’t exist?

[CODE]$ sudo cat /etc/modprobe.d/blacklist.conf
[sudo] :
cat: /etc/modprobe.d/blacklist.conf: No such file or directory

[n-macbookpro54 ~]$ sudo cat /etc/modules-load.d/modules.conf

List of modules to load at boot

b43 [/CODE]

Ok, looks good, go back to the tutorial and run through it again.

1 Like

ls -hl /etc/modprobe.d
shows you what files are in there - check each one

Kernel module - ArchWiki

it’s not about the name of the file - you can call it whatever you like, but it has to end in .conf
it’s about the content of the file

Thanks for that, ran it.

$ ls -hl /etc/modprobe.d
total 4.0K
-rw-r--r-- 1 root root 27 Feb  5 17:13 b43.conf

look what is in there:

cat /etc/modprobe.d/b43.conf