Awful sound quality through the speakers

Hello folks :slightly_smiling_face:
I have bought a new laptop (Asus Scar 15 G533QS) and faced with a problem - awful sound quality through the speakers. Sound good only if I use earphones. On windows I don’t have this problem. I have tried different distros (Xubuntu, Fedora, Mint) to check if this problem exist on them, and yes, it does. All my music via speakers sounds like from barrel with 16-32kbps.

Would be grateful for any help.

inxi -Fza

  Kernel: 6.7.4-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.7-x86_64
    root=UUID=db7642e9-3dca-4011-bf50-1b20d70499da rw rootflags=subvol=@
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G533QS_G533QS v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G533QS v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: G533QS.331
    date: 02/24/2023
  ID-1: BAT0 charge: 90.7 Wh (98.9%) condition: 91.7/90.0 Wh (101.8%)
    power: 4.8 W volts: 17.6 min: 15.9 model: AS3GWAF3KC GA50358 type: Li-ion
    serial: <filter> status: charging
  Info: model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000B
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 607 high: 2537 min/max: 400/4890 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 2537 9: 1580 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 bogomips: 105448
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB]
    vendor: ASUSTeK driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm
    non-free: 545.xx+ status: current (as of 2024-02; EOL~2026-12-xx)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie:
    gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:249c class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 52.0 C
  Display: x11 server: v: compositor: xfwm4 v: 4.18.0
    driver: X: loaded: amdgpu,nvidia unloaded: modesetting,nouveau
    alternate: fbdev,nv,vesa dri: radeonsi gpu: amdgpu display-ID: :0.0
    note: <missing: xdpyinfo/xrandr>
  Monitor-1: eDP-1 model: TL156VDXP0101 built: 2021 res: 1920x1080 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast gbm:
    drv: kms_swrast surfaceless: drv: nvidia x11: drv: radeonsi
    inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.5-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    renoir LLVM 16.0.6 DRM 3.57 6.7.4-2-MANJARO) device-ID: 1002:1638
    memory: 500 MiB unified: no
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
    snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.7.4-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Info: services: NetworkManager,wpa_supplicant
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:2 chip-ID: 13d3:3563
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 4.57 TiB used: 983.91 GiB (21.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S4000G
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: ELFK1N.1 temp: 44.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung
    model: MZVLQ1T0HBLB-00B00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: FXM7201Q temp: 44.9 C scheme: GPT
  ID-1: / raw-size: 150 GiB size: 150 GiB (100.00%) used: 21.67 GiB (14.4%)
    fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:7
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 15.4 MiB (16.0%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-3: /home raw-size: 150 GiB size: 150 GiB (100.00%)
    used: 21.67 GiB (14.4%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:7
  ID-4: /var/log raw-size: 150 GiB size: 150 GiB (100.00%)
    used: 21.67 GiB (14.4%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:7
  Alert: No swap data was found.
  System Temperatures: cpu: 62.0 C mobo: 46.0 C gpu: amdgpu temp: 52.0 C
  Fan Speeds (rpm): cpu: 2200
  Memory: total: 64 GiB note: est. available: 62.23 GiB used: 3.54 GiB (5.7%)
  Processes: 393 Power: uptime: 1m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 24.86 GiB services: upowerd,xfce4-power-manager Init: systemd
    v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1197 libs: 347 tools: pamac Compilers:
    clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26 running-in: xfce4-terminal
    inxi: 3.3.33

is the module avaiable ? post the output of

modinfo snd_pci_acp6x | grep filename
filename:       /lib/modules/6.7.4-2-MANJARO/kernel/sound/soc/amd/yc/snd-pci-acp6x.ko.zst

I have tried to add “snd_pci_acp6x” to file:


but nothing had happened.

Did I understand right, that I have this module on my pc,
and I have to force it to run during boot and check if it helped?

Honestly, I am a bit confused.

Then check, if the module is loaded: lspci | grep audio or inxi -Fza.
(This must be done after a reboot).

Nope. Still: N/A :slightly_frowning_face:

The snd_pci_acp6x driver doesn’t have support for some newer hardware yet. This thread has details on how to build a kernel that does if you’re comfortable with doing that.

1 Like

The solution has been found! :slightly_smiling_face:

1. install: alsa-tools (I chose 'echomixer' in pamac)
2. run in terminal: hdajackretask
3. select code: realtek alc285
4. options: show unconnected pins
5. override:
   5.1. 0x14 -> Internal Speaker (Back)
   5.2. 0x1e -> Internal Speaker (LFE)
6. click: install boot override 
7. reboot 

Thank you guys for responding!


I guess that is just completely bypassing the AMD ACP/ACP3X/ACP6x Audio Coprocessor that doesn’t have a driver? Nice idea!

Speaker outputs are from onboard analog audio device AMD Renoir Radeon High Definition Audio (ALC285)

Audio Coprocessor device is to support internal digital microphones
AMD ACP drivers are similar to Sound Open Firmware drivers on Intel systems

Kernel module paramater model=alc294-lenovo-mic mentioned in Archwiki is to fix internal digital microphones

sound/pci/hda/patch_realtek.c - Linux source code (v6.7.4)

		.type = HDA_FIXUP_PINS,
		.v.pins = (const struct hda_pintbl[]) {
			/* Change the mic location from front to right, otherwise there are
			   two front mics with the same name, pulseaudio can't handle them.
			   This is just a temporary workaround, after applying this fixup,
			   there will be one "Front Mic" and one "Mic" in this machine.
			{ 0x1a, 0x04a19040 },

It may be possible to change mic location for pin 0x1a in hdajackretask to fix internal microphones in addition to re-tasking speaker connections

If re-tasking solution is reported upstream to ALSA developers they can create a patch for future kernel releases

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.