Avvio lento del sistema


#1

Ciao ragazzi…

Fino a qualche tempo fa utilizzavo Debian XFCE, mi trovavo benissimo ma il software non aggiornato ha iniziato a crearmi problemi nel momento in cui ho iniziato a programmare in Python.
Per avere software aggiornato mi è stato consigliato Manjaro. Mi trovo bene ma per poterlo utilizzare come mio sistema principale devo risolvere un problema: la lentezza. Non so per quale motivo, anche solo a decrittare il disco e avviare il SO ci mette una vita rispetto a Debian, ma non solo… Anche nell’uso di tutti i giorni mi sembra più lento. Voi esperti di questo OS cosa mi consigliate?

Premetto che il mio PC monta un SSD da 500GB. Inoltre ho scritto l’immagine più volte, su diverse chiavette USB e persino su un DVD. Ho riformattato più volte il tutto pensando potesse essere andato storto qualcosa durante l’installazione.

Help me please
Sono disperato
Grazie mille


#2

Ah, dimenticavo… Potrebbe esservi utile questo:

[cristian@cristian-pc ~]$ systemd-analyze 
Startup finished in 11.142s (firmware) + 39.009s (loader) + 11.106s (kernel) + 2.284s (userspace) = 1min 3.543s
graphical.target reached after 997ms in userspace

e questo:

[cristian@cristian-pc ~]$ systemd-analyze blame
          1.083s systemd-backlight@backlight:intel_backlight.service
           483ms tlp.service
           396ms dev-mapper-luks\x2d600db412\x2db105\x2d49d1\x2db24c\x2d7afa7a3>
           349ms upower.service
           277ms ModemManager.service
           155ms udisks2.service
           153ms polkit.service
           131ms systemd-rfkill.service
           114ms lightdm.service
           106ms systemd-journal-flush.service
           100ms boot-efi.mount
            93ms NetworkManager.service
            93ms avahi-daemon.service
            80ms bluetooth.service
            75ms lvm2-monitor.service
            71ms systemd-logind.service
            60ms systemd-udev-trigger.service
            53ms grub-boot-indeterminate.service
            52ms systemd-journald.service
            46ms systemd-udevd.service
            43ms user@1000.service
            32ms accounts-daemon.service
            28ms systemd-fsck@dev-disk-by\x2duuid-A6A9\x2d4E30.service
            24ms org.cups.cupsd.service
            18ms systemd-tmpfiles-setup-dev.service
            17ms systemd-modules-load.service
            17ms systemd-tmpfiles-setup.service
            16ms wpa_supplicant.service
            16ms dev-mapper-luks\x2da20d9d4e\x2d0fba\x2d4e26\x2d81d1\x2df552e7f>
            14ms systemd-cryptsetup@luks\x2da20d9d4e\x2d0fba\x2d4e26\x2d81d1\x2>
            13ms sys-kernel-debug.mount
            13ms kmod-static-nodes.service
            12ms systemd-remount-fs.service
            11ms ufw.service
            11ms dev-hugepages.mount
            10ms dev-mqueue.mount
             7ms systemd-update-utmp.service
             6ms systemd-cryptsetup@luks\x2d600db412\x2db105\x2d49d1\x2db24c\x2>
             6ms systemd-sysctl.service
             5ms systemd-user-sessions.service
             5ms systemd-random-seed.service
             5ms rtkit-daemon.service
             3ms sys-fs-fuse-connections.mount
             2ms tmp.mount
             2ms sys-kernel-config.mount
lines 23-45/45 (END)
            28ms systemd-fsck@dev-disk-by\x2duuid-A6A9\x2d4E30.service
            24ms org.cups.cupsd.service
            18ms systemd-tmpfiles-setup-dev.service
            17ms systemd-modules-load.service
            17ms systemd-tmpfiles-setup.service
            16ms wpa_supplicant.service
            16ms dev-mapper-luks\x2da20d9d4e\x2d0fba\x2d4e26\x2d81d1\x2df552e7f62f50.swap
            14ms systemd-cryptsetup@luks\x2da20d9d4e\x2d0fba\x2d4e26\x2d81d1\x2df552e7f62f50.service
            13ms sys-kernel-debug.mount
            13ms kmod-static-nodes.service
            12ms systemd-remount-fs.service
            11ms ufw.service
            11ms dev-hugepages.mount
            10ms dev-mqueue.mount
             7ms systemd-update-utmp.service
             6ms systemd-cryptsetup@luks\x2d600db412\x2db105\x2d49d1\x2db24c\x2d7afa7a3a1bf8.service
             6ms systemd-sysctl.service
             5ms systemd-user-sessions.service
             5ms systemd-random-seed.service
             5ms rtkit-daemon.service
             3ms sys-fs-fuse-connections.mount
             2ms tmp.mount
             2ms sys-kernel-config.mount

#3

Ho trovato un paio di topic che sembrano fare al caso tuo:



#4

Ok, riformattando il tutto e installando il sistema senza criptare il disco, l’avvio risulta essere veloce.

Però non ho capito come risolvere il problema, ovvero come criptare il disco senza rallentare l’avvio del pc. :sweat_smile:


#5

Io non ho mai usato un disco criptato per installare il sistema quindi non è facile nemmeno per me interpretare tutta la discussione, penso che sia una questione di impostazioni durante la creazione del volume criptato, sembra che al momento siano troppo “sicure” le configurazioni e quindi rallentano in modo esagerato i tentativi di immissione password (fa molti round di hash, o qualcosa del genere).