Autostarting ibus daemon

I have tried to autostart the ibus daemon upon logging in using the script:

ibus-daemon --xim --replace --daemonize --panel=/usr/lib/ibus/ibus-ui-gtk3

but it does not happen.

However, if I execute the script after I login, I am able to get the daemon running as usual.

This is something I can live with, but I am seeking a solution, if there is one, for autostarting to work.


How exactly did you try getting it to autostart?

The daemon for ibus should auto start by itself every boot after you use ibus-setup in the terminal. If it isn’t:

If, however, IBus is not autostarted upon login, then move the “export …” lines above to either

  • ~/.xprofile instead and append this line to the same file: ibus-daemon -drx , or
  • ~/.xinitrc and append this line to the same file: ibus-daemon -drx .
  • Another potential option is adding ibus-daemon -drx after the export ... lines in ~/.bashrc .


Using a script that said:

ibus-daemon --xim --replace --daemonize --panel=/usr/lib/ibus/ibus-ui-gtk3

and executing it under KDE System Settings under Autostart.

Thank you. It works!

I added the line

ibus-daemon -drx

after the export lines in ~/.bashrc.

My ~/.bash_profile file calls ~/.bashrc.

the best: ? not sure: bashrc is called every time you open terminal and a “window” in terminal.

1 Like

I just tried removing the environment variables from .bashrc, and plonking them all with the daemon starting command as well, into $HOME/.xprofile so:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon -drx

For the record, iBus autostarts after a cold reboot.

So, I will keep it this way, without involving .bashrc

Please select the solution post (box with a checkmark) so that it is marked as solved :slight_smile:

Several people have already tried that today ─ myself included, as well as two team members ─ but it appears to be broken. It has been reported and it’s being looked into. :man_shrugging:

1 Like

I marked your post as the solution before your above post, but the boxed tick got unticked somehow. Perhaps as @Aragorn has said, the solution box is not working as it should.

It’s looking good now. Issue solved!

CC @Aragorn @realmain


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.