Autostart script by booting not working

By default, wlan is activated immediately after logging in. I want to ensure that this is not the case, so I’m able to switch on the opensnitch firewall first. If possible also automated in the script during startup. On research I tried the following on the picture, but no change happened.

I have created a sh file under /etc/init.d/ and entered the following commands:
nmcli radio wifi off
pkill -15 opensnitch-ui; opensnitch-ui
sudo opensnitchd start
The group is root.

Which procedure is recommended? If the three commands were used successfully, I would manually reactivate wlan after start.
Many thanks in advance

Welcome to the forum! :slight_smile:

Please read the post below. :arrow_down:

1 Like

If I understand your task correct - you want to avoid the network being activated until some point after you have logged in.

What is the point of this? I mean you should be able to run opensnitch as service as well as the network?

1 Like

Actually it would be enough for me to have the firewall running immediately after startup, but I just can’t get it to work.

Have you tried firewalld from the repository?

Opensnitch works, but only if it is started manually. I would like to automate this. Actually I only want to manage the outgoing traffic by single program. As far as I can understand it, this is not possible with firewalld.

You can define outgoing rules in firewalld as well. I have never had the use case but it is possible.


Another option is to create a user-group which is blocked by firewalld and run the application as the mentioned user.