Autostart doesn't work

Before the latest stable update autostart was working but after it is not.
Only works if I put “kate” on launch order, no more. But for example if I put something more like Sleep 15 && kate it wouldn’t work. Or if I put any enviromment variable to get launch with the program on the boot there is no luck either. Before it was working everything but now not. it’s a regression.

1 Like

Have you tried
sleep 15 && /usr/bin/kate
?

I am not able to reproduce your issue

you need to spell Sleep as sleep

when you add an item you are actually creating a .desktop file with the command and desktop files with multipart commands tends to work best if you quote the complete command e.g.

"sleep 15 && kate"

another option is to use a script - remember to chmod +x script.sh

a third thing is - if you create the entry manually in ~/.config/autostart, Plasma may refuse to run the entry unless trusted - which means - chmod +x ~/.config/autostart/entry.desktop

yeah, nothing happens that way either

yeah yeah, I know I have to spell sleep and not Sleep, I have just put bad here.
And not, putting “” doesn’t fix my problem. Have you updated your system? sure?
If are you sure… putting ```
“sleep 15 && kate”

Makes kate to start at boot? try it because I'm putting this and nothing happens

With that, everything works perfect

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.