Automatically Mount Flash Drives

is it possible to tell my os to automatically mount my flash drive without it prompting me?

Yes, it is, but you should be aware that this is dangerous.

System Settings → Hardware → Removable Storage → Removable Devices

Tick the checkbox next to “Enable automatic mounting of removable media”.

how dangerous?

Well, there’s a USB stick going round that was specifically created for the purpose of damaging the hardware of your computer. I’m not sure how it works ─ it’s something electrical ─ but it’s been around for at least a year now.

If it’s triggered by an attempt to read its contents, then that would certainly be a good reason not to have it mounted automatically. :thinking:


well, i’ll keep that in mind, thanks for the help

1 Like

If it’s a specific drive, can it be done in fstab? I know the title says ‘drives’ but for a specific drive it’s not the same.

OP says ‘my flash drive’, not ‘any flash drive’… so I’d go with the UUID in fstab - give it a nice title like ‘RedStick’ and have a permanent mount for it.

If you have the GTK ‘disks’ utility, then once it’s plugged in you can set specific mount options just for that one drive.

1 Like

You can set it up with a designated mountpoint in /etc/fstab, yes, but I’m not sure whether you can also have it automounted that way. I suppose there might be some systemd-related mount option for that, but I’d have to check the man page to be sure. :thinking:

I suspect the noauto option will do exactly that. If it’s not called that, I can’t remember what it’s called.

I use it for one of my hard drives. It only gets mounted when its mount point is accessed, not before like other mounts.

But for that to work, it must be plugged in before trying to access it. (Obviously.)

Yes, but that may not be what the OP wants. :slight_smile:

Or it may. :wink: I don’t know. At least the option is out there now.

An example of an non automatic mount in /etc/fstab:

UUID=c47c5a52-db30-4aef-bcbc-af35b7b021fd    /mnt/4TB        ext4    defaults,noauto 0 1

Hope this helps.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.