Automatic switch sink and microphone pipewire

Hi there,

After last update Pipewire enabled the automatic switching sink which I don’t know how to disable. This is so annoying because my headphones are connected to the case’s front jack plug and at the slightest movement on the wire the audio is streamed to the speakers. This is so annoying. I’d like to disable that automatic switching feature and set a permanent sink even if it is detected as “not connected”.

I tried:

# pactl unload-module module-switch-on-connect

But it says the module is not loaded. I really like Pipewire and Wireplumber and would like to keep those instead of reverting to PulseAudio.

How can I disable this automatic switching feature?

Another question. Pipewire sets any output device as a regular microphone which is weird. If I set the configuration to “Analog Stereo Output” instead of “Stereo Duplex”, which has no input stream, Pipewire detects the headphones as a regular input and even when I mute it, it’s volume comes back to 100% after a few seconds (maybe due to the auto-switching feature and some wire issue). The point is: If there is no input set, Pipewire should not try to “guess” one and the input tab on Pavucontrol should be disabled, right? I think this is how it worked on the previous version.

Thank you in advance.