Auto boot into windows - how to stop it?

Whenever i start my pc it automatically boot into windows 11 without showing mangaro and windows starter window , then i have to go into bios and open open to manjaro…
how can i fix this ??

Hi @spy_rx,

I’m guessing it’s because of Windows overwriting the EFI partition, or the boot order in UEFI/BIOS with every update to be the only one. Forcefully. I’ve heard of it happening before.

Also in the UEFI/BIOS, ensure that fast startup and secure boot is disabled.
Also make sure if there is an option for either somewhere in windows (probably under power management somewhere) it’s disabled there.

More info:


First, keep a manjaro usb close because windows “hijacks” the boot process at major updates, so it will happen again in the future. Also, check the obligatory prerequisites, because there is a possibility the they are reset to defaults: from windows disable the fast boot from the power settings, from bios/uefi disable secure boot and raid0 if you have one.

Then you can follow the guide to restore GRUB

As a second step, you can make your life easier, you can edit the grub config so that the menu always shows and you do not have to hit ESC.

Edit /etc/default/grub an take a look at the following settings, resp. change them:

1 Like

Are both operating systems set to boot in UEFI mode? If you installed Windows in UEFI mode and Manjaro in legacy BIOS emulation (CSM) mode, then that won’t work.


Is Fast Startup enabled in Windows? If so, read on:

Fast startup in Windows 11 allows a quicker boot time when you start your machine - only, it’s just an illusion. Instead, your machine wakes from a hibernation state, because it hasn’t actually shut down.

This behaviour is by design when Fast Startup is enabled; and is extremely undesirable when multibooting Linux and Windows.

The easiest way to disable fast startup is to open a Command Prompt or Windows Terminal, as Administrator, and enter the following command:

powercfg -h off

Then reboot.

After this reboot, Windows will be able to shut down, restart, and startup, normally. Assuming there are no other issues, at your next boot you should see whatever you expected during boot.


If its an issue of windoze hijacking the boot then theres also this:

The boot sequence in the UEFI bios could be changed.