Authentication Password Failure in Manjaro ARM Testing KDE

Hi All,
This issue isn’t present on my main ride, but rather on the ARM version I am trying on an old Android box.

I have tried both the Manjaro ARM (testing) KDE and XFCE versions on this box and keep running into an Authentication Password Failure in KDE.
I turn on display password to double check the password was entered correctly and even tried using 1234 as the password based on a suggestion in another post.
Nothing works.
I read that it may be related to the keyboard, so I tried selecting several different keyboards in the OS (several generic keyboards plus several from the actual manufacturer of my keyboard) but no joy.

If you are wondering why I use the Testing version, it is because this is the only way that I can get Ethernet to work, sadly WiFi does not work.

I searched the forums and found this thread:

However it is two years old and remains unresolved.

If anyone is able to help, I will be most grateful!

Update the algoritm used for the stored passwd

  1. Switch to a TTY
  2. Login as root
  3. Set a new passwd for the account in question
    passwd <account>

If you so desire you can now set passwd back to the previous one

Many thanks @linux-aarhus, I appreciate your help.
I tried your suggestion but unfortunately in Terminal I wasn’t able to switch to root.
For the record I typed SU and when it asked for my password, I entered it and was hit with the same Authentication Failure that I get in pamac.

I specifically mentioned TTY - but if your root passwd is not recognized either - there is something wrong with your configuration elsewhere.

  1. Logout
  2. CtrlAltF4
  3. enter login root
  4. enter root passwd
  5. passwd <account>
  6. enter new passwd (do not reuse)
  7. repeat new password

8. reuse the old password by repeating step 5…7

Then type exit and Enter

Depending on your system - use CtrlAltF7 or CtrlAltF1 to return to your login screen.


@linux-aarhus your solution worked like MAGIC!!!
Thank you very much for your help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.