Authentication failed with package manager

Hi all - My issue is similar to this thread and all the linked ones but none of them worked for me.

This is what I see when I try to install something with the package manager:

The polkit daemon is running:

4 S polkitd      835       1  0  80   0 - 745694 -     Jan30 ?        00:00:01 /usr/lib/polkit-1/polkitd --no-debug
0 S mango      62340   61417  0  80   0 -  1624 -      20:50 pts/0    00:00:00 grep polkit

I am logged into Manjaro using Chrome Remote Desktop, could that be causing this issue?

Are there any other logs I can share to help debug this issue? Note that I can install and upgrade packages from the command line using sudo pamac install but nothing in the UI that requires escalation works.

Thanks in advance!

Do you have polkit-gnome installed?

sudo pacman -S polkit-gnome

Hi @zangman,

This is just a wild guess, but this is what I immediately thought when I saw “…Remote Desktop” along with you mentioning that is works with CLI.

I’m thinking the remote client tries to authenticate against the client’s credentials, while in CLI it authenticates as per usual, with PAM.

Now I know I’m possibly, likely even wrong about this, but since it is remote, perhaps this can be confirmed or not by using something else, if only to test. Perhaps something like VNC.

Or what @ishaan2479 said. :point_up_2:

It’s more likely. :blush: :man_shrugging:

@ishaan2479 - Yes, I have it installed:

polkit-gnome                                             [Installed] 0.105-8  community 
    Legacy polkit authentication agent for GNOME

@Mirdarthos - Hmm, interesting idea, I don’t know if I can use VNC. My other device that I log into this headless device is a chromebook :frowning:

@anon12891489 I don’t have a proc entry in my fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=B65A-BE5F                            /boot/efi      vfat    umask=0077 0 2
UUID=f137a55a-3150-4781-9f00-46044bfcfe2f /              ext4    defaults,noatime 0 1
UUID=b9c6be8d-177b-469c-9ed3-1bce98a9bd1a swap           swap    defaults,noatime 0 0
UUID=F4CAFC8BCAFC4B7E 	/mnt/bigdrive	ntfs-3g          defaults,nofail 0 2
UUID=ddf5fb4a-dc87-4a8a-afe1-0c4f1cb26ca3  /mnt/raid1	ext4	defaults,nofail,noatime 0 2

I searched online and came across this question and tried to run pkexec but it failed. I’m not sure if this has anything to do with my current issue?

pkexec echo "yes"                                                                                                                                                             127 ✘  8s   !1/2  
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ====
Authentication is needed to run `/usr/bin/echo' as the super user
Authenticating as: mango
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
Error executing command as another user: Not authorized

This incident has been reported.

:eyes: now yer in for it!!

Sorry. Not sorry. Just couldn’t help myself. :man_shrugging:

1 Like

LOL - shudder shudder

@Mirdarthos Looks like you were right, it has something to do with chrome remote desktop. I don’t get this error if I login on the machine itself. It works perfectly fine. But searching online doesn’t give me anything :frowning:

Then I can only recommend you search, install and remove packages VIA CLI:

  • To search for a package:
pamac search <keyword>

Where <keyword> is the key word to search for. I usually use the application’s name.

  • To install an package:
pamac install <packageName>
  • To remove the application:
pamac remove <packageName>

Where <packageName> in either of the above steps is the name of the package to be installed or removed.

For more information, see:

man pamac

Yea - that’s what I’ve been doing for the past few months and it works as well as expected. Would be nice to have a gui package manager sometimes though.

Maybe. I prefer the command-line. You can actually copy and paste from there to here if you need assistance and it’s much easier to write “type this” than tell someone “click that”. And they can’t find that to click on it…

I am able to replicate this only if I either enter the wrong password multiple times or I press cancel in the password prompt.



@ishaan2479 - Are you getting the password entering dialog? The problem is I’m not seeing the dialog to enter the password.

I have this very same problem using xrdp and Cinnamon desktop, so I don’t think it is linked to Gnome or Chrome Remote Desktop at all.