AUR won't enable in Openbox

I just installed Manjaro Openbox minimal. It seems to be running without issues, except:

Pamac>Preferences>AUR has greyed out check boxes so that I can’t enable AUR.

Solution?

did you install base-devel group and git… as it’s required for AUR

I had not done that but I have now installed both and still AUR settings in Preferences is not active.

Open a Terminal and edit
/etc/pamac.conf

## Allow Pamac to search and install packages from AUR:
EnableAUR

Did you check
/etc/pamac.conf
EnableAUR
?

No, wasn’t aware and now can’t find it. I haven’t seen any mention of this in the wikis or other how-to’s on the net.

This command takes me to a blank page in Micro. Same with Nano:

sudo micro /etc/pamac.config

here is my config as an example

### Pamac configuration file

## When removing a package, also remove those dependencies
## that are not required by other packages (recurse option):
RemoveUnrequiredDeps

## How often to check for updates, value in hours (0 to disable):
RefreshPeriod = 6

## When there are no updates available, hide the tray icon:
#NoUpdateHideIcon

## When applying updates, enable packages downgrade:
#EnableDowngrade

## When installing packages, do not check for updates:
#SimpleInstall

## Allow Pamac to search and install packages from AUR:
EnableAUR

## Keep built packages from AUR in cache after installation:
KeepBuiltPkgs

## When AUR support is enabled check for updates from AUR:
CheckAURUpdates

## When check updates from AUR support is enabled check for vcs updates:
#CheckAURVCSUpdates

## AUR build directory:
BuildDirectory = /var/tmp

## Number of versions of each package to keep in the cache:
KeepNumPackages = 1

## Remove only the versions of uninstalled packages when clean cache:
#OnlyRmUninstalled

## Download updates in background:
#DownloadUpdates

## Maximum Parallel Downloads:
MaxParallelDownloads = 4

#EnableSnap

#CheckFlatpakUpdates

#EnableFlatpak

is pamac installed correctly?

  • pamac-cli
  • pamac-common
/etc/dbus-1/system.d/org.manjaro.pamac.daemon.conf
/etc/pamac.conf
/etc/xdg/autostart/pamac-tray-budgie.desktop
/usr/bin/dependency-checker
/usr/bin/outdated-checker
/usr/bin/pamac-daemon
/usr/include/pamac.h
/usr/lib/girepository-1.0/Pamac-9.0.typelib
/usr/lib/libpamac.so
/usr/lib/pkgconfig/pamac.pc
/usr/lib/systemd/system/pamac-cleancache.service
/usr/lib/systemd/system/pamac-cleancache.timer
/usr/lib/systemd/system/pamac-daemon.service
/usr/lib/systemd/system/pamac-mirrorlist.service
/usr/lib/systemd/system/pamac-mirrorlist.timer
  • pamac-gtk
  • pamac-snap-plugin

correct folder rights?

ls -al /etc/pamac.conf 
-rw-r--r-- 1 root root 1174 19. Sep 20:00 /etc/pamac.conf
pamac --version
Pamac  9.5.11-1

/etc/pamac.conf

Not .config

Sometimes I’m amazed at how dense I can be :frowning: Thank you for your patience and your help.

1 Like

Very kind you gave me the solution but I didnt do all the hard work so I will change that to @Lila-Kuh 's anwser.

1 Like

I realize the issue has been solved - but as maintainer - I am curious as it sounds strange.

Pamac installs the necessary packages when building from AUR the first time - so any missing packages from base-devel meta should not affect the ability to enable AUR.

May I ask which ISO you used? Is there a bug I need to be aware of?

But you noticed that I had failed to Enable AUR in /etc/pamac.conf The need for that was not mentioned in anything I read.

To answer your question. I attempted to install from the Manjaro-Openbox Minimal ISO which I downloaded from the Manjaro site a couple of days ago and then wrote to a USB stick using SUSE Studio Image Writer. Manjaro-Openbox ran fine when booted from the USB but the installer kept failing, saying it couldn’t partition.

With some help from Linuxquestions.org, I figured out that the installer apparently was getting hung up on a swap partition on my hard drive. I booted from the USB and used Gparted to re-partition the hard drive with no swap. Calamares then installed without any further apparent issues, until I discovered that pamac couldn’t access AUR.

I hope that makes sense. I claim zero proficiency with Linux.

That is because Pamac handles this when you enable AUR in pamac settings. Your OT was originated in the lack of possibility to enable inside Pamac settings. The edit of the pamac.conf is just the manual method which pamac usually handles on it’s own.

Could you provide me with the filename of the ISO you downloaded?

manjaro-openbox-XX.Y.Z-yymmdd-linuxXY...iso

manjaro-openbox-20.0-minimal-200423-linux56.iso

1 Like