AUR update problems

Hey, I have some problem during update of my AUR packages. The following AUR software wants to get updated:
cbkcomp, game-devices-udev, timeshift, v86d

It says corrupted database. I have updates all keys and so on as in another post described. But the error is still be there. In the extended log is no more detailed error to be seen. I can edit the build files, but that was it.

How can I proceed from here in order to debug and solve this?

Checking <application-name> dependencies...
Error: Failed to prepare transaction: invalid or corrupted database

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.

Any ideas how to solve this?

1 Like

All those packages are in the repos.

Please see Pacman-mirrors - Manjaro and post the output of that command if it does not succeed.

Hey, I have run
user $ sudo pacman-mirrors --fasttrack && sudo pacman -Syu
it went smoothly and now two AUR packages are updated.
I have tried that before, but all four packages were the same after that.

In the graphical installer are two packages shown that need to be updated.
ckbcomp, v86d

However, if I re-run the above command I will get the following output

 sudo pacman-mirrors --fasttrack && sudo pacman -Syu
[sudo] password for domgru: 
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool:
::INFO => Mirror status:
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
  0.178 Germany        :
  0.149 Germany        :
  0.195 Germany        :
  0.584 Germany        :
  0.147 Germany        :
::INFO Writing mirror list
::Germany         :$repo/$arch
::Germany         :$repo/$arch
::Germany         :$repo/$arch
::Germany         :$repo/$arch
::Germany         :$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
 there is nothing to do

Not possible. pacman does not handle AUR.

As @Yochanan said those packages are in the repos.

You performed a regular update. (not including AUR)

To also update AUR packages you may use an AUR helper.

For paru:

paru -Sua

For yay:

yay -Sua --devel

Or … pamac, I guess:

pamac upgrade -a

v86d and ckbcomp are in the repos.
Maybe you (or pamac) think they need an update because they also exist in the AUR?

I thought that too. But as a matter of fact. pacman applied the update I have not installed before and after that the graphical installer is showing only two packages left.

What do you mean? Yes, these packages can be found the aur? How does this information will help me?

No, as a matter of fact pacman does not ever update AUR. It may appear that it did, but only because those packages are found in manjaro’s repositories as well as in the AUR.

IMHO there is a typo or unproper use, one ‘y’ is missing. When mirrors are updated, a full refresh of the package database should be forced, the correct syntax should be:

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

There is a messy contradiction in the Manjaro wiki, by the way:

Please create a new topic in Wiki with more details and myself or someone else can take a look.

Tried it, but has not solved the problem.

I was able to solve this. I have recognized if I search for software with the grapical installer, only AUR packages were shown.
I have then refreshed the databases via the graphical installer. The two left over AUR packages were installed after that.

I have no clue why. Can anybody shed some light on this?

Also thanks for your feedback so far in this topic.

-Syyu was suggested if any change was done to mirrors,etc.
But pacman got smarter … 99% of the time the extra ‘y’ is unecessary.
It should only be used if required - which is rare.
(as noted elsewhere … people defaulting to -Syyu, or many people using it, will hammer the servers)

We were only responding to your package ‘problem’ which was not one.
As already stated multiple times - those packages exist in the repos.
Your pacman output was normal.
pamac wanted to upgrade those packages because they have the same name as AUR packages
(and apparently because you never refreshed pamac)

Simple really. Everything was fine. pamac was slightly borked, as it tends to do, and as was outlined in the update announcement and numerous other threads, you were fixated on its broken output without mentioning it explicitly … then you did follow the directions and fixed pamac …

I’m still not sure whether you actually upgraded those packages to their AUR counterparts … and if you did … you probably dont want to … it is just another bug of pamac that it will sometimes replace one with the other if they have the same name … which is doubly problematic because even things like libpamac exist in the AUR.

1 Like

Hey, I think I understood now what you wanted to say. AUR is not in the repo. And the packages should not be updated via AUR. I have not made this distinction before. Thanks for explaining. I will check if the packages are from AUR now and revert this if they are.

Thanks for helping.